aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-06-28 07:32:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-06-28 07:32:12 +0800
commit31d66c20ee7a8e60266f1309c16faa6e61813eba (patch)
tree0a427ce7c1bc39e93fcbebdeca2857559cd20b66 /www
parentac008d8a00f255bd52a5cda610768df3e0be6c52 (diff)
downloadfreebsd-ports-gnome-31d66c20ee7a8e60266f1309c16faa6e61813eba.tar.gz
freebsd-ports-gnome-31d66c20ee7a8e60266f1309c16faa6e61813eba.tar.zst
freebsd-ports-gnome-31d66c20ee7a8e60266f1309c16faa6e61813eba.zip
Add py-priority 1.3.0
Priority is a pure-Python implementation of the priority logic for HTTP/2, set out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients to express a preference for how the server allocates its (limited) resources to the many outstanding HTTP requests that may be running over a single HTTP/2 connection. Specifically, this Python implementation uses a variant of the implementation used in the excellent H2O project. This original implementation is also the inspiration for nghttp2's priority implementation, and generally produces a very clean and even priority stream. The only notable changes from H2O's implementation are small modifications to allow the priority implementation to work cleanly as a separate implementation, rather than being embedded in a HTTP/2 stack directly. While priority information in HTTP/2 is only a suggestion, rather than an enforceable constraint, where possible servers should respect the priority requests of their clients. WWW: https://github.com/python-hyper/priority
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-priority/Makefile20
-rw-r--r--www/py-priority/distinfo3
-rw-r--r--www/py-priority/pkg-descr19
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 05c0d1c9b4a2..5de6186ef15e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1805,6 +1805,7 @@
SUBDIR += py-poster
SUBDIR += py-praw
SUBDIR += py-prewikka
+ SUBDIR += py-priority
SUBDIR += py-puppetboard
SUBDIR += py-puppetboard02
SUBDIR += py-puppetboard03
diff --git a/www/py-priority/Makefile b/www/py-priority/Makefile
new file mode 100644
index 000000000000..b6b9c3b8b36c
--- /dev/null
+++ b/www/py-priority/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= priority
+PORTVERSION= 1.3.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pure-Python implementation of the HTTP/2 priority tree
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/www/py-priority/distinfo b/www/py-priority/distinfo
new file mode 100644
index 000000000000..c3a2b5d3cbc0
--- /dev/null
+++ b/www/py-priority/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530051116
+SHA256 (priority-1.3.0.tar.gz) = 6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe
+SIZE (priority-1.3.0.tar.gz) = 13827
diff --git a/www/py-priority/pkg-descr b/www/py-priority/pkg-descr
new file mode 100644
index 000000000000..8042496947ee
--- /dev/null
+++ b/www/py-priority/pkg-descr
@@ -0,0 +1,19 @@
+Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients to
+express a preference for how the server allocates its (limited) resources to the
+many outstanding HTTP requests that may be running over a single HTTP/2
+connection.
+
+Specifically, this Python implementation uses a variant of the implementation
+used in the excellent H2O project. This original implementation is also the
+inspiration for nghttp2's priority implementation, and generally produces a very
+clean and even priority stream. The only notable changes from H2O's
+implementation are small modifications to allow the priority implementation to
+work cleanly as a separate implementation, rather than being embedded in a
+HTTP/2 stack directly.
+
+While priority information in HTTP/2 is only a suggestion, rather than an
+enforceable constraint, where possible servers should respect the priority
+requests of their clients.
+
+WWW: https://github.com/python-hyper/priority