aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-12 20:46:51 +0800
committerMartin Wilke <miwi@FreeBSD.org>2007-12-12 20:46:51 +0800
commit321b6cb54f5e736a13056d61988ea541252be4ff (patch)
treed57c1ff8e9c1565cd492964738baf4a5fb2911e8 /www
parentb944054f319268c3ba2b04ed28d9841cc1071071 (diff)
downloadfreebsd-ports-gnome-321b6cb54f5e736a13056d61988ea541252be4ff.tar.gz
freebsd-ports-gnome-321b6cb54f5e736a13056d61988ea541252be4ff.tar.zst
freebsd-ports-gnome-321b6cb54f5e736a13056d61988ea541252be4ff.zip
Staticmatic lets you manage static websites with Haml & Sass.
WWW: http://staticmatic.rubyforge.org/ PR: ports/118078 Submitted by: Robert Gogolok <gogo at cs.uni-sb.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-staticmatic/Makefile21
-rw-r--r--www/rubygem-staticmatic/distinfo3
-rw-r--r--www/rubygem-staticmatic/pkg-descr3
-rw-r--r--www/rubygem-staticmatic/pkg-plist103
5 files changed, 131 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 42d6d4c63a1f..317ff617f454 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1120,6 +1120,7 @@
SUBDIR += rubygem-rubyfulsoup
SUBDIR += rubygem-scrapi
SUBDIR += rubygem-scrubyt
+ SUBDIR += rubygem-staticmatic
SUBDIR += rubygem-taggable
SUBDIR += sams
SUBDIR += sarg
diff --git a/www/rubygem-staticmatic/Makefile b/www/rubygem-staticmatic/Makefile
new file mode 100644
index 000000000000..094ceb712a9d
--- /dev/null
+++ b/www/rubygem-staticmatic/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-staticmatic
+# Date created: 15 November 2007
+# Whom: Robert Gogolok <gogo@cs.uni-sb.de>
+#
+# $FreeBSD$
+
+PORTNAME= staticmatic
+PORTVERSION= 0.9.0
+CATEGORIES= www rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gogo@cs.uni-sb.de
+COMMENT= Manage static websites using Haml and Sass
+
+RUN_DEPENDS= rubygem-haml>=1.7.0:${PORTSDIR}/www/rubygem-haml \
+ rubygem-mongrel>=1.0.1:${PORTSDIR}/www/rubygem-mongrel
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-staticmatic/distinfo b/www/rubygem-staticmatic/distinfo
new file mode 100644
index 000000000000..2e360186dc3c
--- /dev/null
+++ b/www/rubygem-staticmatic/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/staticmatic-0.9.0.gem) = 0867984a8afc96aa9f53e9d23dfd1302
+SHA256 (rubygem/staticmatic-0.9.0.gem) = e014ac0253e3244e1de31d393be2c770e20d7082188bb569155aa53a8000bb9a
+SIZE (rubygem/staticmatic-0.9.0.gem) = 216576
diff --git a/www/rubygem-staticmatic/pkg-descr b/www/rubygem-staticmatic/pkg-descr
new file mode 100644
index 000000000000..62394826676d
--- /dev/null
+++ b/www/rubygem-staticmatic/pkg-descr
@@ -0,0 +1,3 @@
+Staticmatic lets you manage static websites with Haml & Sass.
+
+WWW: http://staticmatic.rubyforge.org/
diff --git a/www/rubygem-staticmatic/pkg-plist b/www/rubygem-staticmatic/pkg-plist
new file mode 100644
index 000000000000..b08fd15a85d6
--- /dev/null
+++ b/www/rubygem-staticmatic/pkg-plist
@@ -0,0 +1,103 @@
+bin/staticmatic
+%%CACHE_DIR%%/staticmatic-0.9.0.gem
+%%GEM_LIB_DIR%%/CHANGELOG
+%%GEM_LIB_DIR%%/LICENSE
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/bin/staticmatic
+%%GEM_LIB_DIR%%/example/site/contact.html
+%%GEM_LIB_DIR%%/example/site/index.html
+%%GEM_LIB_DIR%%/example/site/stylesheets/application.css
+%%GEM_LIB_DIR%%/example/src/layouts/application.haml
+%%GEM_LIB_DIR%%/example/src/pages/contact.haml
+%%GEM_LIB_DIR%%/example/src/pages/index.haml
+%%GEM_LIB_DIR%%/example/src/stylesheets/application.sass
+%%GEM_LIB_DIR%%/lib/staticmatic.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/base.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/configuration.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/error.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/helpers.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/server.rb
+%%GEM_LIB_DIR%%/lib/staticmatic/templates/application.haml
+%%GEM_LIB_DIR%%/lib/staticmatic/templates/application.sass
+%%GEM_LIB_DIR%%/lib/staticmatic/templates/index.haml
+%%GEM_LIB_DIR%%/lib/staticmatic/version.rb
+%%GEM_LIB_DIR%%/test/base_test.rb
+%%GEM_LIB_DIR%%/test/helpers_test.rb
+%%GEM_LIB_DIR%%/test/sandbox/test_site/configuration.rb
+%%GEM_LIB_DIR%%/test/sandbox/test_site/site/index.html
+%%GEM_LIB_DIR%%/test/sandbox/test_site/site/stylesheets/application.css
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/helpers/application_helper.rb
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/layouts/alternate_layout.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/layouts/application.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/layouts/projects.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/pages/index.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/pages/layout_test.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/partials/menu.haml
+%%GEM_LIB_DIR%%/test/sandbox/test_site/src/stylesheets/application.sass
+%%GEM_LIB_DIR%%/test/server_test.rb
+%%GEM_LIB_DIR%%/test/test_helper.rb
+%%GEM_LIB_DIR%%/test/test_helper_test.rb
+%%GEM_LIB_DIR%%/test/version_test.rb
+%%GEM_LIB_DIR%%/website/site/download.html
+%%GEM_LIB_DIR%%/website/site/faq.html
+%%GEM_LIB_DIR%%/website/site/how_to_use.html
+%%GEM_LIB_DIR%%/website/site/images/bycurve21.gif
+%%GEM_LIB_DIR%%/website/site/images/curve21.jpg
+%%GEM_LIB_DIR%%/website/site/images/homepage-build.jpg
+%%GEM_LIB_DIR%%/website/site/images/homepage-previewing.jpg
+%%GEM_LIB_DIR%%/website/site/images/homepage-templating.jpg
+%%GEM_LIB_DIR%%/website/site/index.html
+%%GEM_LIB_DIR%%/website/site/releases/0_8_10.html
+%%GEM_LIB_DIR%%/website/site/releases/0_8_4.html
+%%GEM_LIB_DIR%%/website/site/releases/0_8_8.html
+%%GEM_LIB_DIR%%/website/site/releases/0_9_0.html
+%%GEM_LIB_DIR%%/website/site/stylesheets/application.css
+%%GEM_LIB_DIR%%/website/src/helpers/application_helper.rb
+%%GEM_LIB_DIR%%/website/src/layouts/application.haml
+%%GEM_LIB_DIR%%/website/src/layouts/test.haml
+%%GEM_LIB_DIR%%/website/src/pages/download.haml
+%%GEM_LIB_DIR%%/website/src/pages/faq.haml
+%%GEM_LIB_DIR%%/website/src/pages/how_to_use.haml
+%%GEM_LIB_DIR%%/website/src/pages/index.haml
+%%GEM_LIB_DIR%%/website/src/pages/releases/0_8_10.haml
+%%GEM_LIB_DIR%%/website/src/pages/releases/0_8_4.haml
+%%GEM_LIB_DIR%%/website/src/pages/releases/0_8_8.haml
+%%GEM_LIB_DIR%%/website/src/pages/releases/0_9_0.haml
+%%GEM_LIB_DIR%%/website/src/partials/news.haml
+%%SPEC_DIR%%/staticmatic-0.9.0.gemspec
+@dirrm %%GEM_LIB_DIR%%/website/src/partials
+@dirrm %%GEM_LIB_DIR%%/website/src/pages/releases
+@dirrm %%GEM_LIB_DIR%%/website/src/pages
+@dirrm %%GEM_LIB_DIR%%/website/src/layouts
+@dirrm %%GEM_LIB_DIR%%/website/src/helpers
+@dirrm %%GEM_LIB_DIR%%/website/src
+@dirrm %%GEM_LIB_DIR%%/website/site/stylesheets
+@dirrm %%GEM_LIB_DIR%%/website/site/releases
+@dirrm %%GEM_LIB_DIR%%/website/site/images
+@dirrm %%GEM_LIB_DIR%%/website/site
+@dirrm %%GEM_LIB_DIR%%/website
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src/stylesheets
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src/partials
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src/pages
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src/layouts
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src/helpers
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/src
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/site/stylesheets
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site/site
+@dirrm %%GEM_LIB_DIR%%/test/sandbox/test_site
+@dirrm %%GEM_LIB_DIR%%/test/sandbox
+@dirrm %%GEM_LIB_DIR%%/test
+@dirrm %%GEM_LIB_DIR%%/lib/staticmatic/templates
+@dirrm %%GEM_LIB_DIR%%/lib/staticmatic
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%/example/src/stylesheets
+@dirrm %%GEM_LIB_DIR%%/example/src/pages
+@dirrm %%GEM_LIB_DIR%%/example/src/layouts
+@dirrm %%GEM_LIB_DIR%%/example/src
+@dirrm %%GEM_LIB_DIR%%/example/site/stylesheets
+@dirrm %%GEM_LIB_DIR%%/example/site
+@dirrm %%GEM_LIB_DIR%%/example
+@dirrm %%GEM_LIB_DIR%%/bin
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%