aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2014-01-12 01:46:33 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2014-01-12 01:46:33 +0800
commit324c5236b888759ebda3ce7af2aba391da348ea0 (patch)
tree2f8ae2a36fa3a470da851493054d7f7fafb0b259 /www
parent5d776fa056c0b1c619072b2c1bc87f52687f2fd5 (diff)
downloadfreebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.tar.gz
freebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.tar.zst
freebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.zip
- Change default location of Go packages to LOCALBASE/share/go
This fixes problems like ports failing to build if the port is already installed [1] - Bump PORTREVISION of affected ports - Support the install target in bsd.go.mk - STAGE support for free! PR: ports/180003 [1]
Diffstat (limited to 'www')
-rw-r--r--www/webgo/Makefile12
-rw-r--r--www/webgo/pkg-plist46
2 files changed, 27 insertions, 31 deletions
diff --git a/www/webgo/Makefile b/www/webgo/Makefile
index b0c2643970c1..1ced8db0a912 100644
--- a/www/webgo/Makefile
+++ b/www/webgo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webgo
PORTVERSION= 0.1.0.${SVNVERSION}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/jlaffaye
DISTNAME= ${PORTNAME}-${SVNVERSION}
@@ -12,16 +13,7 @@ COMMENT= Simplest way to write web applications in the Go programming language
SVNVERSION= 20120419
-GO_PKGNAME= ${SUBLIBDIR}/web
-
-SUBLIBDIR= github.com/hoisie
-
-NO_STAGE= yes
-do-install:
- ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/web.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
- (cd ${GO_WRKSRC}/ && ${COPYTREE_SHARE} \* ${GO_LOCAL_SRCDIR}/${GO_PKGNAME})
+GO_PKGNAME= github.com/hoisie/web
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
diff --git a/www/webgo/pkg-plist b/www/webgo/pkg-plist
index 2fd9928ffcc7..59c5ee53a5b9 100644
--- a/www/webgo/pkg-plist
+++ b/www/webgo/pkg-plist
@@ -1,23 +1,27 @@
-%%GO_LIBDIR%%/github.com/hoisie/web.a
-go/src/pkg/%%GO_PKGNAME%%/LICENSE
-go/src/pkg/%%GO_PKGNAME%%/Makefile
-go/src/pkg/%%GO_PKGNAME%%/Readme.md
-go/src/pkg/%%GO_PKGNAME%%/fcgi.go
-go/src/pkg/%%GO_PKGNAME%%/scgi.go
-go/src/pkg/%%GO_PKGNAME%%/status.go
-go/src/pkg/%%GO_PKGNAME%%/web.go
-go/src/pkg/%%GO_PKGNAME%%/web_test.go
-go/src/pkg/%%GO_PKGNAME%%/examples/Makefile
-go/src/pkg/%%GO_PKGNAME%%/examples/arcchallenge.go
-go/src/pkg/%%GO_PKGNAME%%/examples/hello.go
-go/src/pkg/%%GO_PKGNAME%%/examples/logger.go
-go/src/pkg/%%GO_PKGNAME%%/examples/methodhandler.go
-go/src/pkg/%%GO_PKGNAME%%/examples/multipart.go
-go/src/pkg/%%GO_PKGNAME%%/examples/multiserver.go
-go/src/pkg/%%GO_PKGNAME%%/examples/params.go
-@dirrm go/src/pkg/%%GO_PKGNAME%%/examples
-@dirrm go/src/pkg/%%GO_PKGNAME%%
-@dirrmtry go/src/pkg/github.com/hoisie
-@dirrmtry go/src/pkg/github.com/
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/Makefile
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/Readme.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/Makefile
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/arcchallenge.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/hello.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/logger.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/methodhandler.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/multipart.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/multiserver.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/params.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/fcgi.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/scgi.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/status.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/web.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/web_test.go
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/examples
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/github.com/hoisie
+@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
@dirrmtry %%GO_LIBDIR%%/github.com/hoisie
@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go