aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-08 04:53:45 +0800
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-08 04:53:45 +0800
commit3366a8de369b040be58c8830e788269b4e5772fb (patch)
tree76d0c762cd8cfd883965394d90cf22ad88b201e3 /www
parent23de73159ea8b9113f1586e9a2f301db86fd55e8 (diff)
downloadfreebsd-ports-gnome-3366a8de369b040be58c8830e788269b4e5772fb.tar.gz
freebsd-ports-gnome-3366a8de369b040be58c8830e788269b4e5772fb.tar.zst
freebsd-ports-gnome-3366a8de369b040be58c8830e788269b4e5772fb.zip
- Fix -A and -a options for apxs to correctly ignore whitespace.
This will fix about 100 pkg-plist left overs for httpd.conf - Bump PORTREVISION - This will be in 2.2.16. PR: ports/133704 Obtained from: http://svn.apache.org/viewvc?rev=942210&view=rev Reported by: olli hauer <ohauer@gmx.de> (and very good pr!) With Hat: apache@
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/patch-support__apxs.in23
2 files changed, 23 insertions, 2 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 8769bba263bb..28a43460c4fd 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/patch-support__apxs.in b/www/apache22/files/patch-support__apxs.in
index f07805469c9a..e98a7792c5c9 100644
--- a/www/apache22/files/patch-support__apxs.in
+++ b/www/apache22/files/patch-support__apxs.in
@@ -1,6 +1,27 @@
--- ./support/apxs.in.orig 2006-07-11 23:38:44.000000000 -0400
+++ ./support/apxs.in 2010-05-06 19:37:54.268730293 -0400
-@@ -619,8 +619,7 @@
+@@ -547,7 +547,10 @@
+ $c = '#' if ($opt_A);
+ foreach $lmd (@lmd) {
+ my $what = $opt_A ? "preparing" : "activating";
+- if ($content !~ m|\n#?\s*$lmd|) {
++ my $lmd_re = $lmd;
++ $lmd_re =~ s/\s+/\\s+/g;
++
++ if ($content !~ m|\n#?\s*$lmd_re|) {
+ # check for open <containers>, so that the new LoadModule
+ # directive always appears *outside* of an <container>.
+
+@@ -610,7 +613,7 @@
+ }
+ } else {
+ # replace already existing LoadModule line
+- $content =~ s|^(.*\n)#?\s*$lmd[^\n]*\n|$1$c$lmd\n|s;
++ $content =~ s|^(.*\n)#?\s*$lmd_re[^\n]*\n|$1$c$lmd\n|s;
+ }
+ $lmd =~ m|LoadModule\s+(.+?)_module.*|;
+ notice("[$what module `$1' in $CFG_SYSCONFDIR/$CFG_TARGET.conf]");
+@@ -619,8 +622,7 @@
if (open(FP, ">$CFG_SYSCONFDIR/$CFG_TARGET.conf.new")) {
print FP $content;
close(FP);