aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-07-27 05:44:37 +0800
committerrakuco <rakuco@FreeBSD.org>2017-07-27 05:44:37 +0800
commit36e2ce147d15aaccd518332108a6825e5b37b8aa (patch)
tree6dcbd8fc45118eb052919e07fc4c93dc6111bb18 /www
parent257e8084faa164820c5f335b444f4845dde91f78 (diff)
downloadfreebsd-ports-gnome-36e2ce147d15aaccd518332108a6825e5b37b8aa.tar.gz
freebsd-ports-gnome-36e2ce147d15aaccd518332108a6825e5b37b8aa.tar.zst
freebsd-ports-gnome-36e2ce147d15aaccd518332108a6825e5b37b8aa.zip
Force an older C++ standard than C++11 to build.
This fixes the build with GCC >= 6, which use C++11 by default. This version of anyterm is not compatible with C++11. PR: 219296 Approved by: Douglas Thrift <douglas@douglasthrift.net>
Diffstat (limited to 'www')
-rw-r--r--www/anyterm/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index 6b63ac0750d4..49bfd143bb31 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -28,6 +28,10 @@ ALL_TARGET= default_target
PLIST_FILES= man/man1/anytermd.1.gz \
sbin/anytermd
+# Force the use of an older C++ standard; anyterm 1.1.29 is not compatible with
+# C++11.
+USE_CXXSTD= gnu++03
+
post-patch:
@${REINPLACE_CMD} -e 's|/private/etc/apache2|${FILESDIR}|' \
${WRKSRC}/scripts/mimetype.sh