aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-09-02 13:17:56 +0800
committermarcus <marcus@FreeBSD.org>2005-09-02 13:17:56 +0800
commit36e767a90efea2a47f85d63e4a3e2bdbbd897283 (patch)
tree8bcb8e1df8a70e567c6c1e6eb6b22e877903a926 /www
parent3af06efa182421faaee3cbab41d3c38f8c5942fa (diff)
downloadfreebsd-ports-gnome-36e767a90efea2a47f85d63e4a3e2bdbbd897283.tar.gz
freebsd-ports-gnome-36e767a90efea2a47f85d63e4a3e2bdbbd897283.tar.zst
freebsd-ports-gnome-36e767a90efea2a47f85d63e4a3e2bdbbd897283.zip
The calendar module is broken in this 1.8 beta, so disable it.
PR: 84578
Diffstat (limited to 'www')
-rw-r--r--www/mozilla-devel/Makefile17
-rw-r--r--www/seamonkey/Makefile17
-rw-r--r--www/seamonkey2/Makefile17
3 files changed, 24 insertions, 27 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 9e4703bd4c4d..6dd0c277e3eb 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -95,8 +95,7 @@ JPI_LIST?=\
${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-OPTIONS=CALENDAR "Enable the Calendar module" off \
- MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
@@ -122,10 +121,10 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
illegibly. Please remove the mozilla-fonts package
.endif
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= Calendar requires Composer and Mailnews support.
-.endif
+#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+# defined(WITHOUT_COMPOSER))
+#BROKEN= Calendar requires Composer and Mailnews support.
+#.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
@@ -183,9 +182,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-.if defined(WITH_CALENDAR)
-CONFIGURE_ARGS+= --enable-calendar
-.endif
+#.if defined(WITH_CALENDAR)
+#CONFIGURE_ARGS+= --enable-calendar
+#.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 9e4703bd4c4d..6dd0c277e3eb 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -95,8 +95,7 @@ JPI_LIST?=\
${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-OPTIONS=CALENDAR "Enable the Calendar module" off \
- MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
@@ -122,10 +121,10 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
illegibly. Please remove the mozilla-fonts package
.endif
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= Calendar requires Composer and Mailnews support.
-.endif
+#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+# defined(WITHOUT_COMPOSER))
+#BROKEN= Calendar requires Composer and Mailnews support.
+#.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
@@ -183,9 +182,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-.if defined(WITH_CALENDAR)
-CONFIGURE_ARGS+= --enable-calendar
-.endif
+#.if defined(WITH_CALENDAR)
+#CONFIGURE_ARGS+= --enable-calendar
+#.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 9e4703bd4c4d..6dd0c277e3eb 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -95,8 +95,7 @@ JPI_LIST?=\
${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-OPTIONS=CALENDAR "Enable the Calendar module" off \
- MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
@@ -122,10 +121,10 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
illegibly. Please remove the mozilla-fonts package
.endif
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= Calendar requires Composer and Mailnews support.
-.endif
+#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+# defined(WITHOUT_COMPOSER))
+#BROKEN= Calendar requires Composer and Mailnews support.
+#.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
@@ -183,9 +182,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-.if defined(WITH_CALENDAR)
-CONFIGURE_ARGS+= --enable-calendar
-.endif
+#.if defined(WITH_CALENDAR)
+#CONFIGURE_ARGS+= --enable-calendar
+#.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer