aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-03-17 19:28:59 +0800
committerMark Linimon <linimon@FreeBSD.org>2021-03-17 19:28:59 +0800
commit3767954d1980e6b3f554936b671457d8add4fc7d (patch)
tree3140b1635e8c7dce6d8a683971a51176b1511d52 /www
parentfa7f08b96c44816407cd81aa3827ae0fb3fce15b (diff)
downloadfreebsd-ports-gnome-3767954d1980e6b3f554936b671457d8add4fc7d.tar.gz
freebsd-ports-gnome-3767954d1980e6b3f554936b671457d8add4fc7d.tar.zst
freebsd-ports-gnome-3767954d1980e6b3f554936b671457d8add4fc7d.zip
Add USE_CSTD=c99 to fix build on GCC-based systems:
main.c:58: error: 'for' loop initial declaration used outside C99 mode While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'www')
-rw-r--r--www/vger/Makefile4
-rw-r--r--www/vger/pkg-descr2
2 files changed, 4 insertions, 2 deletions
diff --git a/www/vger/Makefile b/www/vger/Makefile
index 5b2327c9da70..206d7aa54e86 100644
--- a/www/vger/Makefile
+++ b/www/vger/Makefile
@@ -9,9 +9,12 @@ DISTFILES= 365e99400a8a13546c4c060f28e23bf81d68d45e.tar.gz
MAINTAINER= nc@FreeBSD.org
COMMENT= Simplistic and secure Gemini server
+
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_CSTD= c99
+
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
@@ -22,4 +25,3 @@ post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}/gemini
.include <bsd.port.mk>
-
diff --git a/www/vger/pkg-descr b/www/vger/pkg-descr
index a2c5fcbe753d..0471713fb642 100644
--- a/www/vger/pkg-descr
+++ b/www/vger/pkg-descr
@@ -5,4 +5,4 @@ Vger design is relying on inetd and a daemon to take care of TLS. The idea is
to delegate TLS and network to daemons which proved doing it correctly, so vger
takes its request from stdin and output the result to stdout.
-https://tildegit.org/solene/vger
+WWW: https://tildegit.org/solene/vger