aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2013-04-23 23:15:49 +0800
committerolgeni <olgeni@FreeBSD.org>2013-04-23 23:15:49 +0800
commit396936e1454531f79f7863f0e6c2739d38550c9d (patch)
tree9a3e7dd856adb001b5d6298b757f89941df5267e /www
parent51631a536cdea4808457b0a5f53ebfedb9ab4cd5 (diff)
downloadfreebsd-ports-gnome-396936e1454531f79f7863f0e6c2739d38550c9d.tar.gz
freebsd-ports-gnome-396936e1454531f79f7863f0e6c2739d38550c9d.tar.zst
freebsd-ports-gnome-396936e1454531f79f7863f0e6c2739d38550c9d.zip
Add www/mochiweb, an Erlang library for building lightweight HTTP
servers. This is the original version from Mochi Media, Inc.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mochiweb/Makefile46
-rw-r--r--www/mochiweb/distinfo2
-rw-r--r--www/mochiweb/pkg-descr4
-rw-r--r--www/mochiweb/pkg-plist85
5 files changed, 138 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 91756e0962d1..8a7c39f7bb61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -448,6 +448,7 @@
SUBDIR += mkapachepw
SUBDIR += mknmz-wwwoffle
SUBDIR += mnogosearch
+ SUBDIR += mochiweb
SUBDIR += mod_amazon_proxy
SUBDIR += mod_antiloris
SUBDIR += mod_asn
diff --git a/www/mochiweb/Makefile b/www/mochiweb/Makefile
new file mode 100644
index 000000000000..f263dc0f64d2
--- /dev/null
+++ b/www/mochiweb/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= mochiweb
+PORTVERSION= 2.6.0
+CATEGORIES= www devel
+MASTER_SITES= GH
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Erlang library for building lightweight HTTP servers
+
+LICENSE= MIT
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+USE_GITHUB= yes
+GH_ACCOUNT= mochi
+GH_PROJECT= mochiweb
+GH_COMMIT= 92b8f5b
+GH_TAGNAME= v${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+do-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @for FILE in CHANGES.md README; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${FILE} ${DOCSDIR}; \
+ done
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/ebin
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/include
+ @${MKDIR} ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/src
+ @${INSTALL_DATA} ${WRKSRC}/ebin/* ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/ebin
+ @${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/include
+ @${INSTALL_DATA} ${WRKSRC}/src/* ${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/src
+
+.include <bsd.port.post.mk>
diff --git a/www/mochiweb/distinfo b/www/mochiweb/distinfo
new file mode 100644
index 000000000000..266f75fec648
--- /dev/null
+++ b/www/mochiweb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mochiweb-2.6.0.tar.gz) = e0805c1bda2e0bf0ef7f198a0bf5b4cf322c64d9c01ed674fe0ec4e6459c65a7
+SIZE (mochiweb-2.6.0.tar.gz) = 205598
diff --git a/www/mochiweb/pkg-descr b/www/mochiweb/pkg-descr
new file mode 100644
index 000000000000..5323a5663f62
--- /dev/null
+++ b/www/mochiweb/pkg-descr
@@ -0,0 +1,4 @@
+MochiWeb is an Erlang library for building lightweight HTTP servers,
+from Mochi Media, Inc.
+
+WWW: https://github.com/mochi/mochiweb
diff --git a/www/mochiweb/pkg-plist b/www/mochiweb/pkg-plist
new file mode 100644
index 000000000000..2e433d56fb5a
--- /dev/null
+++ b/www/mochiweb/pkg-plist
@@ -0,0 +1,85 @@
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt_records.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochifmt_std.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiglobal.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochihex.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochijson.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochijson2.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochilists.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochilogfile2.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochinum.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochitemp.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiutf8.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb.app
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_acceptor.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_base64url.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_charref.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_cookies.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_cover.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_echo.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_headers.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_html.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_http.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_io.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_mime.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_multipart.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_request.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_request_tests.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_response.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_session.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_socket.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_socket_server.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/mochiweb_util.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin/reloader.beam
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/include/internal.hrl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt_records.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochifmt_std.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiglobal.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochihex.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochijson.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochijson2.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochilists.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochilogfile2.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochinum.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochitemp.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiutf8.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb.app.src
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_acceptor.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_base64url.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_charref.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_cookies.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_cover.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_echo.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_headers.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_html.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_http.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_io.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_mime.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_multipart.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_request.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_request_tests.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_response.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_session.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_socket.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_socket_server.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_util.erl
+%%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src/reloader.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api.hrl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api_client.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api_lib.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/https_store.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/server_cert.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https/server_key.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keepalive/keepalive.erl
+@dirrm %%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/src
+@dirrm %%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/include
+@dirrm %%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%/ebin
+@dirrm %%LIB32DIR%%/erlang/lib/mochiweb-%%VERSION%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/keepalive
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/https
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hmac_api
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%