aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-19 22:26:05 +0800
committerrm <rm@FreeBSD.org>2012-10-19 22:26:05 +0800
commit3abff1f05fae65269d42097f11ee690e01f01b9b (patch)
tree8a061947706ff63786c3bbefa4f96faf37d9b302 /www
parent4fba6ab4141a839c40531fc62003e9c995430d86 (diff)
downloadfreebsd-ports-gnome-3abff1f05fae65269d42097f11ee690e01f01b9b.tar.gz
freebsd-ports-gnome-3abff1f05fae65269d42097f11ee690e01f01b9b.tar.zst
freebsd-ports-gnome-3abff1f05fae65269d42097f11ee690e01f01b9b.zip
- Update to 0.15.0
- Tweak USE_PYTHON version - Add TEST_DEPENDS and regression-test: target - Add LICENSE - Add TORNADO and TESTS - Add NO_OPTIONS_SORT - Tweak OPTIONS descriptions - Trim Makefile header - Whitespace alignment PR: 172875 Submitted by: Kubilay Kocak <koobs.freebsd at gmail dot com> (maintainer) Tested by: redports Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/py-gunicorn/Makefile42
-rw-r--r--www/py-gunicorn/distinfo4
-rw-r--r--www/py-gunicorn/pkg-descr4
3 files changed, 32 insertions, 18 deletions
diff --git a/www/py-gunicorn/Makefile b/www/py-gunicorn/Makefile
index c6d9af116ae7..0551b6875318 100644
--- a/www/py-gunicorn/Makefile
+++ b/www/py-gunicorn/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: py-gunicorn
-# Date created: 2010-03-03
-# Whom: Kristaps Kulis <kristaps.kulis@gmail.com>
-#
+# Created by: Kristaps Kulis <kristaps.kulis@gmail.com>
# $FreeBSD$
-#
PORTNAME= gunicorn
-PORTVERSION= 0.14.5
+PORTVERSION= 0.15.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,15 +10,22 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs.freebsd@gmail.com
COMMENT= Python WSGI server for unix
-USE_PYTHON= 2.5-2.7
+LICENSE= MIT
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
-OPTIONS_DEFINE= EVENTLET GEVENT SETPROC
-EVENTLET_DESC= Add Eventlet asynchronous worker
-GEVENT_DESC= Add Gevent asynchronous worker
-SETPROC_DESC= Change process name support
+OPTIONS_DEFINE= EVENTLET GEVENT TORNADO SETPROC TESTS
+EVENTLET_DESC= Add Eventlet async worker
+GEVENT_DESC= Add Gevent async worker
+TORNADO_DESC= Add Tornado async worker
+SETPROC_DESC= Support changing process title (setproctitle)
+TESTS_DESC= Install nose for running unittests
-OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+NO_OPTIONS_SORT= yes
.include <bsd.port.options.mk>
@@ -31,11 +34,22 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}eventlet>=0.9:${PORTSDIR}/net/py-eventlet
.endif
.if ${PORT_OPTIONS:MGEVENT}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gevent/__init__.py:${PORTSDIR}/devel/py-gevent
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gevent>0:${PORTSDIR}/devel/py-gevent
+.endif
+
+.if ${PORT_OPTIONS:MTORNADO}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.2:${PORTSDIR}/www/py-tornado
.endif
.if ${PORT_OPTIONS:MSETPROC}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/setproctitle.so:${PORTSDIR}/devel/py-setproctitle
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setproctitle>0:${PORTSDIR}/devel/py-setproctitle
.endif
+.if ${PORT_OPTIONS:MTESTS}
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+.endif
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} nosetests
+
.include <bsd.port.mk>
diff --git a/www/py-gunicorn/distinfo b/www/py-gunicorn/distinfo
index 011ba2d76643..ffb2357a6814 100644
--- a/www/py-gunicorn/distinfo
+++ b/www/py-gunicorn/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gunicorn-0.14.5.tar.gz) = cef7820010cc5d1bf134e25b0ab22097b67886ae72c42a774d555be605a9b422
-SIZE (gunicorn-0.14.5.tar.gz) = 228742
+SHA256 (gunicorn-0.15.0.tar.gz) = 811f7e9b6b81f5ef4ba07ba071ee8f09ce2c9b16824b75fcaf6452af8bc9a9ad
+SIZE (gunicorn-0.15.0.tar.gz) = 119108
diff --git a/www/py-gunicorn/pkg-descr b/www/py-gunicorn/pkg-descr
index a2e40527b2a4..ed66aea6ca0f 100644
--- a/www/py-gunicorn/pkg-descr
+++ b/www/py-gunicorn/pkg-descr
@@ -1,6 +1,6 @@
Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX.
-It's a pre-fork worker model ported from Ruby's Unicorn project.
+It's a pre-fork worker model ported from Ruby's Unicorn project.
The Gunicorn server is broadly compatible with various web frameworks,
simply implemented, light on server resource usage, and fairly speedy.
-WWW: http://gunicorn.org/
+WWW: http://gunicorn.org/