aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2016-03-21 00:40:10 +0800
committerolivierd <olivierd@FreeBSD.org>2016-03-21 00:40:10 +0800
commit3d93d42673a44be547ec6d918fe2fef503a8405b (patch)
tree14511b61a71d7b8c0a312e438d552ec9408c2c70 /www
parentd028bfd465dae964c0c45fe255ef35a5441a102f (diff)
downloadfreebsd-ports-gnome-3d93d42673a44be547ec6d918fe2fef503a8405b.tar.gz
freebsd-ports-gnome-3d93d42673a44be547ec6d918fe2fef503a8405b.tar.zst
freebsd-ports-gnome-3d93d42673a44be547ec6d918fe2fef503a8405b.zip
LibDOM is an implementation of the W3C DOM, written in C.
WWW: http://www.netsurf-browser.org/projects/libdom/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/libdom/Makefile33
-rw-r--r--www/libdom/distinfo2
-rw-r--r--www/libdom/files/patch-Makefile13
-rw-r--r--www/libdom/files/patch-libdom.pc.in10
-rw-r--r--www/libdom/pkg-descr3
-rw-r--r--www/libdom/pkg-plist100
7 files changed, 162 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 31871535d6c3..1f1f4a79e8cd 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -365,6 +365,7 @@
SUBDIR += larbin
SUBDIR += lessc
SUBDIR += libapreq2
+ SUBDIR += libdom
SUBDIR += libecap
SUBDIR += libepc
SUBDIR += libevhtp
diff --git a/www/libdom/Makefile b/www/libdom/Makefile
new file mode 100644
index 000000000000..0340949e4e81
--- /dev/null
+++ b/www/libdom/Makefile
@@ -0,0 +1,33 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= libdom
+PORTVERSION= 0.3.0
+CATEGORIES= www
+MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Document Object Model library
+
+LICENSE= MIT
+
+BUILD_DEPENDS= netsurf-buildsystem>=1.5:${PORTSDIR}/devel/netsurf-buildsystem
+LIB_DEPENDS= libwapcaplet.so:${PORTSDIR}/textproc/libwapcaplet \
+ libparserutils.so:${PORTSDIR}/devel/libparserutils \
+ libhubbub.so:${PORTSDIR}/www/libhubbub \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+
+USES= gmake localbase pkgconfig
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
+
+MAKE_ENV+= COMPONENT_TYPE="lib-shared"
+
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libdom.so*
+
+.include <bsd.port.mk>
diff --git a/www/libdom/distinfo b/www/libdom/distinfo
new file mode 100644
index 000000000000..9abc810968e5
--- /dev/null
+++ b/www/libdom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libdom-0.3.0-src.tar.gz) = 8a6c3eb8fcd9beb2e0df660caeb043dfff86632a00b8997cbcbef4a7f0c266ce
+SIZE (libdom-0.3.0-src.tar.gz) = 868852
diff --git a/www/libdom/files/patch-Makefile b/www/libdom/files/patch-Makefile
new file mode 100644
index 000000000000..47a26762ca82
--- /dev/null
+++ b/www/libdom/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2016-02-16 10:52:18 UTC
++++ Makefile
+@@ -145,8 +145,8 @@ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/html_iframe_element.h
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/html_isindex_element.h
+
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
++INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
++INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
+
+ ifeq ($(WITH_LIBXML_BINDING),yes)
+ REQUIRED_PKGS := $(REQUIRED_PKGS) libxml-2.0
diff --git a/www/libdom/files/patch-libdom.pc.in b/www/libdom/files/patch-libdom.pc.in
new file mode 100644
index 000000000000..c2c8ec3eed81
--- /dev/null
+++ b/www/libdom/files/patch-libdom.pc.in
@@ -0,0 +1,10 @@
+--- libdom.pc.in.orig 2016-02-16 10:52:18 UTC
++++ libdom.pc.in
+@@ -1,6 +1,6 @@
+ prefix=PREFIX
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/LIBDIR
++libdir=${exec_prefix}/lib
+ includedir=${prefix}/INCLUDEDIR
+
+ Name: libdom
diff --git a/www/libdom/pkg-descr b/www/libdom/pkg-descr
new file mode 100644
index 000000000000..332c19e66f83
--- /dev/null
+++ b/www/libdom/pkg-descr
@@ -0,0 +1,3 @@
+LibDOM is an implementation of the W3C DOM, written in C.
+
+WWW: http://www.netsurf-browser.org/projects/libdom/
diff --git a/www/libdom/pkg-plist b/www/libdom/pkg-plist
new file mode 100644
index 000000000000..1026c7e43b83
--- /dev/null
+++ b/www/libdom/pkg-plist
@@ -0,0 +1,100 @@
+include/dom/bindings/hubbub/errors.h
+include/dom/bindings/hubbub/parser.h
+include/dom/bindings/xml/xmlerror.h
+include/dom/bindings/xml/xmlparser.h
+include/dom/core/attr.h
+include/dom/core/cdatasection.h
+include/dom/core/characterdata.h
+include/dom/core/comment.h
+include/dom/core/doc_fragment.h
+include/dom/core/document.h
+include/dom/core/document_type.h
+include/dom/core/element.h
+include/dom/core/entity_ref.h
+include/dom/core/exceptions.h
+include/dom/core/implementation.h
+include/dom/core/namednodemap.h
+include/dom/core/node.h
+include/dom/core/nodelist.h
+include/dom/core/pi.h
+include/dom/core/string.h
+include/dom/core/text.h
+include/dom/core/typeinfo.h
+include/dom/dom.h
+include/dom/events/custom_event.h
+include/dom/events/document_event.h
+include/dom/events/event.h
+include/dom/events/event_listener.h
+include/dom/events/event_target.h
+include/dom/events/events.h
+include/dom/events/keyboard_event.h
+include/dom/events/mouse_event.h
+include/dom/events/mouse_multi_wheel_event.h
+include/dom/events/mouse_wheel_event.h
+include/dom/events/mutation_event.h
+include/dom/events/mutation_name_event.h
+include/dom/events/text_event.h
+include/dom/events/ui_event.h
+include/dom/functypes.h
+include/dom/html/html_anchor_element.h
+include/dom/html/html_applet_element.h
+include/dom/html/html_area_element.h
+include/dom/html/html_base_element.h
+include/dom/html/html_basefont_element.h
+include/dom/html/html_body_element.h
+include/dom/html/html_br_element.h
+include/dom/html/html_button_element.h
+include/dom/html/html_collection.h
+include/dom/html/html_directory_element.h
+include/dom/html/html_div_element.h
+include/dom/html/html_dlist_element.h
+include/dom/html/html_document.h
+include/dom/html/html_element.h
+include/dom/html/html_elements.h
+include/dom/html/html_fieldset_element.h
+include/dom/html/html_font_element.h
+include/dom/html/html_form_element.h
+include/dom/html/html_frame_element.h
+include/dom/html/html_frameset_element.h
+include/dom/html/html_head_element.h
+include/dom/html/html_heading_element.h
+include/dom/html/html_hr_element.h
+include/dom/html/html_html_element.h
+include/dom/html/html_iframe_element.h
+include/dom/html/html_image_element.h
+include/dom/html/html_input_element.h
+include/dom/html/html_isindex_element.h
+include/dom/html/html_label_element.h
+include/dom/html/html_legend_element.h
+include/dom/html/html_li_element.h
+include/dom/html/html_link_element.h
+include/dom/html/html_map_element.h
+include/dom/html/html_menu_element.h
+include/dom/html/html_meta_element.h
+include/dom/html/html_mod_element.h
+include/dom/html/html_object_element.h
+include/dom/html/html_olist_element.h
+include/dom/html/html_opt_group_element.h
+include/dom/html/html_option_element.h
+include/dom/html/html_options_collection.h
+include/dom/html/html_paragraph_element.h
+include/dom/html/html_param_element.h
+include/dom/html/html_pre_element.h
+include/dom/html/html_quote_element.h
+include/dom/html/html_script_element.h
+include/dom/html/html_select_element.h
+include/dom/html/html_style_element.h
+include/dom/html/html_table_element.h
+include/dom/html/html_tablecaption_element.h
+include/dom/html/html_tablecell_element.h
+include/dom/html/html_tablecol_element.h
+include/dom/html/html_tablerow_element.h
+include/dom/html/html_tablesection_element.h
+include/dom/html/html_text_area_element.h
+include/dom/html/html_title_element.h
+include/dom/html/html_ulist_element.h
+include/dom/inttypes.h
+lib/libdom.so
+lib/libdom.so.0
+lib/libdom.so.%%VERSION%%
+libdata/pkgconfig/libdom.pc