aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2015-06-26 05:06:39 +0800
committerosa <osa@FreeBSD.org>2015-06-26 05:06:39 +0800
commit401b28277d1a3ba07a657c005a5657721c87987c (patch)
tree4c42a88e60df88c0c067f31c6640168d4b961456 /www
parentf8df15d79e22c04bf0cf67b3411e010891316631 (diff)
downloadfreebsd-ports-gnome-401b28277d1a3ba07a657c005a5657721c87987c.tar.gz
freebsd-ports-gnome-401b28277d1a3ba07a657c005a5657721c87987c.tar.zst
freebsd-ports-gnome-401b28277d1a3ba07a657c005a5657721c87987c.zip
Be more accurate with tmpdir removal and remove only empty tmpdir.
Cause otherwise removal non-empty tmpdir breaks running nginx instance. Bump PORTREVISION. PR: 201045 Tested by: grembo
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/pkg-plist2
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/pkg-plist2
4 files changed, 6 insertions, 3 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f48a202520d1..3516ab2917d7 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -1020,6 +1021,7 @@ do-build:
do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${MKDIR} ${STAGEDIR}${NGINX_TMPDIR}
${INSTALL_PROGRAM} ${WRKSRC}/objs/nginx ${STAGEDIR}${PREFIX}/sbin
.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${STAGEDIR}${ETCDIR}
diff --git a/www/nginx-devel/pkg-plist b/www/nginx-devel/pkg-plist
index df0a1025e643..3a99b7bc61aa 100644
--- a/www/nginx-devel/pkg-plist
+++ b/www/nginx-devel/pkg-plist
@@ -24,5 +24,5 @@
%%WWWDATA%%@exec chmod a-w %D/www/nginx-dist
%%WWWDATA%%@unexec if [ -L %D/www/nginx ]; then rm -f %D/www/nginx; fi
sbin/nginx
-@unexec if [ -z ${UPGRADE_PORT} ] ; then rm -fr %%NGINX_TMPDIR%%; fi
+@dir %%NGINX_TMPDIR%%
man/man8/nginx.8.gz
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 89b6644c786a..6e20021086f4 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -986,6 +986,7 @@ do-build:
do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${MKDIR} ${STAGEDIR}${NGINX_TMPDIR}
${INSTALL_PROGRAM} ${WRKSRC}/objs/nginx ${STAGEDIR}${PREFIX}/sbin
.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${STAGEDIR}${ETCDIR}
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index df0a1025e643..3a99b7bc61aa 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -24,5 +24,5 @@
%%WWWDATA%%@exec chmod a-w %D/www/nginx-dist
%%WWWDATA%%@unexec if [ -L %D/www/nginx ]; then rm -f %D/www/nginx; fi
sbin/nginx
-@unexec if [ -z ${UPGRADE_PORT} ] ; then rm -fr %%NGINX_TMPDIR%%; fi
+@dir %%NGINX_TMPDIR%%
man/man8/nginx.8.gz