aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-01 07:31:37 +0800
committermarino <marino@FreeBSD.org>2014-10-01 07:31:37 +0800
commit43f4633ca61121368ac278a295d507f30e0ee999 (patch)
treeb99b302d5df3c21f04437c229a27a992bbf87ce1 /www
parent10d9cacd7ac15216f712d555206dd13f89535cd1 (diff)
downloadfreebsd-ports-gnome-43f4633ca61121368ac278a295d507f30e0ee999.tar.gz
freebsd-ports-gnome-43f4633ca61121368ac278a295d507f30e0ee999.tar.zst
freebsd-ports-gnome-43f4633ca61121368ac278a295d507f30e0ee999.zip
www/mohawk: Unbreak on DragonFly, remove useless LDFLAG
The provided LDFLAG of -L${LOCALBASE}/lib/event2 would have stopped working after libevent2.so moved to ${LOCALBASE}/lib had the LDFLAG affected anything. The LDFLAG is set by Makefile.inc, and the handling of DragonFly is wrong for ports, although it might still be correct for pkgsrc. Fix that with a patch and remove the LDFLAG that doesn't do anything. No revbump required.
Diffstat (limited to 'www')
-rw-r--r--www/mohawk/Makefile1
-rw-r--r--www/mohawk/files/patch-Makefile.inc16
2 files changed, 16 insertions, 1 deletions
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index cc551de9e1c0..6b83c5d07f93 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -25,7 +25,6 @@ PORTEXAMPLES= *
USE_RC_SUBR= mohawk
CFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib/event2
OPTIONS_DEFINE= EXAMPLES
diff --git a/www/mohawk/files/patch-Makefile.inc b/www/mohawk/files/patch-Makefile.inc
new file mode 100644
index 000000000000..8869e0fabd01
--- /dev/null
+++ b/www/mohawk/files/patch-Makefile.inc
@@ -0,0 +1,16 @@
+--- Makefile.inc.orig 2014-09-15 17:40:01 UTC
++++ Makefile.inc
+@@ -16,13 +16,8 @@ OSVERSION!= sysctl -n kern.osreldate
+ YFLAGS+= -i
+ CLEANFILES+= parse.i
+ .endif
+-.if ${OPSYS} == "DragonFly"
+-LDFLAGS+= -L${PREFIX}/lib/event2
+-LDADD+= -levent-2.0
+-.else
+ LDFLAGS+= -L${PREFIX}/lib
+ LDADD+= -levent
+-.endif
+
+ .elif ${OPSYS} == "NetBSD"
+ PREFIX?= /usr/pkg