aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoralonso <alonso@FreeBSD.org>2014-12-20 06:23:38 +0800
committeralonso <alonso@FreeBSD.org>2014-12-20 06:23:38 +0800
commit47937f2b4d6f8b5b164f7d3f97aeac80586f1e54 (patch)
tree655e6b5703d066d9a075f3e595317e2a22365c06 /www
parentd348ed5b57ce3c14b04025afa85c8082eddf804d (diff)
downloadfreebsd-ports-gnome-47937f2b4d6f8b5b164f7d3f97aeac80586f1e54.tar.gz
freebsd-ports-gnome-47937f2b4d6f8b5b164f7d3f97aeac80586f1e54.tar.zst
freebsd-ports-gnome-47937f2b4d6f8b5b164f7d3f97aeac80586f1e54.zip
Fix build of www/otter-browser
The qmake port is required to be installed when compiling otter. While this requirement is usually met due to its dependencies on qt5 elements which depend on qmake, in case someone uninstalled qmake which is not a runtime dependency for any qt5* port, otter would not build any more. Resolve this introducing a dependency on qmake. Reported by a build cluster, log: http://beefy2.isc.freebsd.org/data/10amd64-default/2014-12-17_04h21m21s/logs/otter-browser-0.9.03.log Approved by: rakuco (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/otter-browser/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index 105259ea3fc6..a5a81b512caa 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -10,10 +10,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Browser based on Qt 5
-BROKEN= Fails to configure
-
-USE_QT5= concurrent core gui network printsupport script sql webkit \
- widgets buildtools_build
+USE_QT5= concurrent core gui network printsupport qmake_build script \
+ sql webkit widgets buildtools_build
USES= cmake:outsource desktop-file-utils
USE_GITHUB= yes