aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
committertz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
commit4827d6341c8195df448c86d232c0a643ba3aceaa (patch)
tree751612430d8a08dd5989d9992db1e4cabdd5ea9c /www
parent4494d7dc520498523a4d72377b421a7319f42162 (diff)
downloadfreebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.gz
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.zst
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.zip
PHP 7.1 and PHP 7.2: add TEST_TARGET to all extensions
This enables "make test" in every extension and eases the test of changes to PHP. I did ignore PHP 7.0 intentionally since it only receives security updates and will EOL at the end of the year. Therefore no great amount of work is expected for 7.0.
Diffstat (limited to 'www')
-rw-r--r--www/php71-opcache/Makefile2
-rw-r--r--www/php71-session/Makefile2
-rw-r--r--www/php71-tidy/Makefile2
-rw-r--r--www/php72-opcache/Makefile2
-rw-r--r--www/php72-session/Makefile2
-rw-r--r--www/php72-tidy/Makefile2
6 files changed, 12 insertions, 0 deletions
diff --git a/www/php71-opcache/Makefile b/www/php71-opcache/Makefile
index 732536ae9d02..416a3540249f 100644
--- a/www/php71-opcache/Makefile
+++ b/www/php71-opcache/Makefile
@@ -6,6 +6,8 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -opcache
+TEST_TARGET= test
+
USES= php:zend,noflavors
.include "${MASTERDIR}/Makefile"
diff --git a/www/php71-session/Makefile b/www/php71-session/Makefile
index 04d66615707d..555b487453f0 100644
--- a/www/php71-session/Makefile
+++ b/www/php71-session/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -session
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/php71-tidy/Makefile b/www/php71-tidy/Makefile
index 9812d425ba90..a22fe3945fc2 100644
--- a/www/php71-tidy/Makefile
+++ b/www/php71-tidy/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -tidy
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/php72-opcache/Makefile b/www/php72-opcache/Makefile
index 5e1f01b8b5d0..134d41a04e51 100644
--- a/www/php72-opcache/Makefile
+++ b/www/php72-opcache/Makefile
@@ -6,6 +6,8 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -opcache
+TEST_TARGET= test
+
USES= php:zend,noflavors
.include "${MASTERDIR}/Makefile"
diff --git a/www/php72-session/Makefile b/www/php72-session/Makefile
index d4886620ea20..acf7755f1ed5 100644
--- a/www/php72-session/Makefile
+++ b/www/php72-session/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -session
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/php72-tidy/Makefile b/www/php72-tidy/Makefile
index c822add61de4..4ec107d3fd72 100644
--- a/www/php72-tidy/Makefile
+++ b/www/php72-tidy/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -tidy
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"