aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-04-15 19:11:16 +0800
committerstas <stas@FreeBSD.org>2007-04-15 19:11:16 +0800
commit482cec0fae307124744b6affa1e81b3837d6c95a (patch)
treea2d7f21611aa661b15c9227291ea61fe5e5440bd /www
parente28d62591ced9e56cd32dc8378c910a45fd764c0 (diff)
downloadfreebsd-ports-gnome-482cec0fae307124744b6affa1e81b3837d6c95a.tar.gz
freebsd-ports-gnome-482cec0fae307124744b6affa1e81b3837d6c95a.tar.zst
freebsd-ports-gnome-482cec0fae307124744b6affa1e81b3837d6c95a.zip
This module sets httpd process titles to reflect the request currently
processed, so they will be visible in top(1) or ps(1). Useful for debugging purposes. Author: Stanislav Sedov <stas@FreeBSD.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_proctitle/Makefile25
-rw-r--r--www/mod_proctitle/distinfo3
-rw-r--r--www/mod_proctitle/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 19a8d3420315..4347bc28de8b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -380,6 +380,7 @@
SUBDIR += mod_ntlm
SUBDIR += mod_perl
SUBDIR += mod_perl2
+ SUBDIR += mod_proctitle
SUBDIR += mod_proxy_add_forward
SUBDIR += mod_proxy_html
SUBDIR += mod_proxy_xml
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
new file mode 100644
index 000000000000..762c599f2213
--- /dev/null
+++ b/www/mod_proctitle/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mod_proctitle
+# Date created: 15 April 2007
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_proctitle
+PORTVERSION= 0.2
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.springdaemons.com/soft/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Set httpd process titles to reflect currently processed request
+
+USE_APACHE?= 2.0+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+PLIST_FILES= ${APACHEMODDIR}/${PORTNAME}.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/mod_proctitle.so \
+ ${PREFIX}/${APACHEMODDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/mod_proctitle/distinfo b/www/mod_proctitle/distinfo
new file mode 100644
index 000000000000..668fe0ee7f22
--- /dev/null
+++ b/www/mod_proctitle/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_proctitle-0.2.tar.bz2) = efd63c4ba7ee40dcf24e5b91e2d29335
+SHA256 (mod_proctitle-0.2.tar.bz2) = 5890646cfb5eb42f5aae445ba814c96519bdaefea79df883d6610287bec29519
+SIZE (mod_proctitle-0.2.tar.bz2) = 202806
diff --git a/www/mod_proctitle/pkg-descr b/www/mod_proctitle/pkg-descr
new file mode 100644
index 000000000000..908918c3a086
--- /dev/null
+++ b/www/mod_proctitle/pkg-descr
@@ -0,0 +1,5 @@
+This module sets httpd process titles to reflect the request currently
+processed, so they will be visible in top(1) or ps(1). Useful for
+debugging purposes.
+
+Author: Stanislav Sedov <stas@FreeBSD.org>