aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-29 01:07:58 +0800
committermiwi <miwi@FreeBSD.org>2008-12-29 01:07:58 +0800
commit4adf4f636527879e27e83a4214bf4c56fecb62f2 (patch)
tree26852232423305bdcf48714bc5b6a4c1f58a6c73 /www
parent264d749b5d3f418449c9142f63c1840aad9a9aa7 (diff)
downloadfreebsd-ports-gnome-4adf4f636527879e27e83a4214bf4c56fecb62f2.tar.gz
freebsd-ports-gnome-4adf4f636527879e27e83a4214bf4c56fecb62f2.tar.zst
freebsd-ports-gnome-4adf4f636527879e27e83a4214bf4c56fecb62f2.zip
CHeMS is a free (as in freedom) modular code-driven content helper
management system (the first!) written in PHP fully compliant with the XHTML 1.1 and CSS2 standards. One of its main purpose is to help developers and (not so) advanced users to easily setting up a web application (blog, site, etc.) without have to deal with the "boring" side of this process such as layout generation code, menu blocks and so on. Its modularization system allow to mantain a light and fast core which only have to generate the layout and load the modules to delegate all the real and hard work to them. You never have to learn new weird APIs in order to deal with the CHeMS internals, there is full controll. That's why CHeMS is not a Content Management System (CMS) but rather it's an assistant. WWW: http://chems.sf.net
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/chems/Makefile39
-rw-r--r--www/chems/distinfo3
-rw-r--r--www/chems/files/pkg-message.in11
-rw-r--r--www/chems/pkg-descr14
-rw-r--r--www/chems/pkg-plist73
6 files changed, 141 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 53620e74477a..e6e721d49875 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -85,6 +85,7 @@
SUBDIR += cgiwrap
SUBDIR += checkbot
SUBDIR += cheetah
+ SUBDIR += chems
SUBDIR += cherokee
SUBDIR += chimera
SUBDIR += chpasswd
diff --git a/www/chems/Makefile b/www/chems/Makefile
new file mode 100644
index 000000000000..4d7471fbcee4
--- /dev/null
+++ b/www/chems/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: www/chems
+# Date created: 2008-12-28
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chems
+DISTVERSION= 0x03_1
+CATEGORIES= www
+MASTER_SITES= SF
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= The geekest content helper management system
+
+NO_BUILD= yes
+USE_ZIP= yes
+USE_PHP= xml iconv gd
+SUB_FILES= pkg-message
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}
+ ${TOUCH} ${WWWDIR}/usr/config.php
+ @${CHOWN} ${WWWOWN} ${WWWDIR}/usr/config.php
+ @${CAT} ${PKGMESSAGE}
+
+create-plist:
+ @${FIND} -s ${WRKSRC}/${file} -not -type d \
+ | ${SED} -e 's,^${WRKSRC},%%WWWDIR%%,' > ${PLIST}
+ @${ECHO_CMD} '@exec touch %D/%%WWWDIR%%/usr/config.php;chown ${WWWOWN} %D/%%WWWDIR%%/usr/config.php' >> ${PLIST}
+ @${ECHO_CMD} '@unexec if [ ! -s %D/%%WWWDIR%%/usr/config.php ];then rm -f %D/%%WWWDIR%%/usr/config.php;fi' >> ${PLIST}
+ @${FIND} -ds ${WRKSRC}/${file} -type d \
+ | ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/www/chems/distinfo b/www/chems/distinfo
new file mode 100644
index 000000000000..3c278b575485
--- /dev/null
+++ b/www/chems/distinfo
@@ -0,0 +1,3 @@
+MD5 (chems-0x03_1.zip) = 00614d9132e65366fb744009d7549948
+SHA256 (chems-0x03_1.zip) = 8c35fcecf299348261e22dff1b211d975351cbb01fd7e5b61ca273ac877dd06e
+SIZE (chems-0x03_1.zip) = 116002
diff --git a/www/chems/files/pkg-message.in b/www/chems/files/pkg-message.in
new file mode 100644
index 000000000000..94f3c486efbb
--- /dev/null
+++ b/www/chems/files/pkg-message.in
@@ -0,0 +1,11 @@
+mybb has been installed into:
+
+ %%WWWDIR%%
+
+You will probably want to add an alias to your httpd.conf file,
+somethinglike this:
+
+ Alias /chems "%%WWWDIR%%"
+
+And restart Apache.
+
diff --git a/www/chems/pkg-descr b/www/chems/pkg-descr
new file mode 100644
index 000000000000..4d419e099431
--- /dev/null
+++ b/www/chems/pkg-descr
@@ -0,0 +1,14 @@
+CHeMS is a free (as in freedom) modular code-driven content helper
+management system (the first!) written in PHP fully compliant with
+the XHTML 1.1 and CSS2 standards. One of its main purpose is to help
+developers and (not so) advanced users to easily setting up a web
+application (blog, site, etc.) without have to deal with the "boring"
+side of this process such as layout generation code, menu blocks and
+so on. Its modularization system allow to mantain a light and fast core
+which only have to generate the layout and load the modules to delegate
+all the real and hard work to them. You never have to learn new weird
+APIs in order to deal with the CHeMS internals, there is full controll.
+That's why CHeMS is not a Content Management System (CMS) but rather it's
+an assistant.
+
+WWW: http://chems.sf.net
diff --git a/www/chems/pkg-plist b/www/chems/pkg-plist
new file mode 100644
index 000000000000..90e706e647e7
--- /dev/null
+++ b/www/chems/pkg-plist
@@ -0,0 +1,73 @@
+%%WWWDIR%%/Changes
+%%WWWDIR%%/docs/COPYING
+%%WWWDIR%%/docs/FAQs
+%%WWWDIR%%/docs/GUIDE
+%%WWWDIR%%/docs/MODULES
+%%WWWDIR%%/docs/README
+%%WWWDIR%%/index.php
+%%WWWDIR%%/modules/blogroll/README
+%%WWWDIR%%/modules/blogroll/blogroll.php
+%%WWWDIR%%/modules/categories/README
+%%WWWDIR%%/modules/categories/categories.php
+%%WWWDIR%%/modules/comments/README
+%%WWWDIR%%/modules/comments/comments.php
+%%WWWDIR%%/modules/commons.php
+%%WWWDIR%%/modules/freehands/README
+%%WWWDIR%%/modules/freehands/freehands.php
+%%WWWDIR%%/modules/navbar/README
+%%WWWDIR%%/modules/navbar/navbar.php
+%%WWWDIR%%/modules/pages_mgr/README
+%%WWWDIR%%/modules/pages_mgr/pages_mgr.php
+%%WWWDIR%%/modules/posts_mgr/README
+%%WWWDIR%%/modules/posts_mgr/posts_mgr.php
+%%WWWDIR%%/modules/posts_mgr/posts_mgr_functions.php
+%%WWWDIR%%/modules/rssfeeds/README
+%%WWWDIR%%/modules/rssfeeds/mkfeeds.php
+%%WWWDIR%%/modules/rssfeeds/rssfeeds.php
+%%WWWDIR%%/modules/showfiles/README
+%%WWWDIR%%/modules/showfiles/showfiles.php
+%%WWWDIR%%/src/cdb.php
+%%WWWDIR%%/src/functions.php
+%%WWWDIR%%/src/main.php
+%%WWWDIR%%/themes/colorlite/README
+%%WWWDIR%%/themes/colorlite/colorlite.css
+%%WWWDIR%%/themes/colorlite/colorlite.theme
+%%WWWDIR%%/themes/colorlite/favicon.ico
+%%WWWDIR%%/themes/monochrome/favicon.ico
+%%WWWDIR%%/themes/monochrome/monochrome.css
+%%WWWDIR%%/themes/monochrome/monochrome.theme
+%%WWWDIR%%/usr/config.php
+%%WWWDIR%%/usr/images/feed.png
+%%WWWDIR%%/usr/images/header.png
+%%WWWDIR%%/usr/images/logo.png
+%%WWWDIR%%/usr/images/meta/anybrowser.png
+%%WWWDIR%%/usr/images/meta/cc-by-sa30.png
+%%WWWDIR%%/usr/images/meta/chems0x03.png
+%%WWWDIR%%/usr/images/meta/css2.png
+%%WWWDIR%%/usr/images/meta/hacker.png
+%%WWWDIR%%/usr/images/meta/rss2.png
+%%WWWDIR%%/usr/images/meta/xhtml11.png
+%%WWWDIR%%/usr/modconf.php
+%%WWWDIR%%/usr/pages.inc
+%%WWWDIR%%/usr/posts.inc
+@exec touch %D/%%WWWDIR%%/usr/config.php;chown www %D/%%WWWDIR%%/usr/config.php
+@unexec if [ ! -s %D/%%WWWDIR%%/usr/config.php ];then rm -f %D/%%WWWDIR%%/usr/config.php;fi
+@dirrm %%WWWDIR%%/docs
+@dirrm %%WWWDIR%%/modules/blogroll
+@dirrm %%WWWDIR%%/modules/categories
+@dirrm %%WWWDIR%%/modules/comments
+@dirrm %%WWWDIR%%/modules/freehands
+@dirrm %%WWWDIR%%/modules/navbar
+@dirrm %%WWWDIR%%/modules/pages_mgr
+@dirrm %%WWWDIR%%/modules/posts_mgr
+@dirrm %%WWWDIR%%/modules/rssfeeds
+@dirrm %%WWWDIR%%/modules/showfiles
+@dirrm %%WWWDIR%%/modules
+@dirrm %%WWWDIR%%/src
+@dirrm %%WWWDIR%%/themes/colorlite
+@dirrm %%WWWDIR%%/themes/monochrome
+@dirrm %%WWWDIR%%/themes
+@dirrm %%WWWDIR%%/usr/images/meta
+@dirrm %%WWWDIR%%/usr/images
+@dirrm %%WWWDIR%%/usr
+@dirrm %%WWWDIR%%/