aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-10-12 19:32:32 +0800
committermat <mat@FreeBSD.org>2004-10-12 19:32:32 +0800
commit4c429e73156c1c0be69906f818c8593aba46a92a (patch)
tree436b9f9c015c1219ee163b8cdc79a3d4f3a0ae2e /www
parent7ca5905d046dade22d570dfd8b27b99e801ee380 (diff)
downloadfreebsd-ports-gnome-4c429e73156c1c0be69906f818c8593aba46a92a.tar.gz
freebsd-ports-gnome-4c429e73156c1c0be69906f818c8593aba46a92a.tar.zst
freebsd-ports-gnome-4c429e73156c1c0be69906f818c8593aba46a92a.zip
Add p5-Apache-Session-Wrapper 0.17, a simple wrapper around
Apache::Session.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-Session-Wrapper/Makefile35
-rw-r--r--www/p5-Apache-Session-Wrapper/distinfo2
-rw-r--r--www/p5-Apache-Session-Wrapper/pkg-descr12
-rw-r--r--www/p5-Apache-Session-Wrapper/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 544600adbd89..560581296060 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -396,6 +396,7 @@
SUBDIR += p5-Apache-Session
SUBDIR += p5-Apache-Session-PHP
SUBDIR += p5-Apache-Session-SharedMem
+ SUBDIR += p5-Apache-Session-Wrapper
SUBDIR += p5-Apache-SubProcess
SUBDIR += p5-Apache-Test
SUBDIR += p5-ApacheBench
diff --git a/www/p5-Apache-Session-Wrapper/Makefile b/www/p5-Apache-Session-Wrapper/Makefile
new file mode 100644
index 000000000000..6024625fe658
--- /dev/null
+++ b/www/p5-Apache-Session-Wrapper/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Apache-Session-Wrapper
+# Date created: 20 Sep 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Session-Wrapper
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A simple wrapper around Apache::Session
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Apache::Session::Wrapper.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-Class-Container whichs needs perl 5.6.x or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Session-Wrapper/distinfo b/www/p5-Apache-Session-Wrapper/distinfo
new file mode 100644
index 000000000000..62071d8a6932
--- /dev/null
+++ b/www/p5-Apache-Session-Wrapper/distinfo
@@ -0,0 +1,2 @@
+MD5 (Apache-Session-Wrapper-0.17.tar.gz) = c7876bad731c2e407816e2ee434ecb14
+SIZE (Apache-Session-Wrapper-0.17.tar.gz) = 17662
diff --git a/www/p5-Apache-Session-Wrapper/pkg-descr b/www/p5-Apache-Session-Wrapper/pkg-descr
new file mode 100644
index 000000000000..d7688feb600c
--- /dev/null
+++ b/www/p5-Apache-Session-Wrapper/pkg-descr
@@ -0,0 +1,12 @@
+This module is a simple wrapper around Apache::Session which provides some
+methods to simplify getting and setting the session id.
+
+It can uses cookies to store the session id, or it can look in a provided
+object for a specific parameter. Alternately, you can simply provide the
+session id yourself in the call to the session() method.
+
+If you're using Mason, you should probably take a look at
+MasonX::Request::WithApacheSession first, which integrates this module directly
+into Mason.
+
+WWW: http://search.cpan.org/dist/Apache-Session-Wrapper/
diff --git a/www/p5-Apache-Session-Wrapper/pkg-plist b/www/p5-Apache-Session-Wrapper/pkg-plist
new file mode 100644
index 000000000000..7da3d4850602
--- /dev/null
+++ b/www/p5-Apache-Session-Wrapper/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Apache/Session/Wrapper.pm
+@unexec rmdir %D/%%SITE_PERL%%/Apache/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true