aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-02-21 14:50:43 +0800
committerclsung <clsung@FreeBSD.org>2005-02-21 14:50:43 +0800
commit4d264bce95ffcb5f16e7c8663a6eb2ee0c310bc7 (patch)
treed40f7203cc94d775635c10863a1a5b3b388fcb1a /www
parente8146703eb6cd2783b4e67cbf8a412cda71b4406 (diff)
downloadfreebsd-ports-gnome-4d264bce95ffcb5f16e7c8663a6eb2ee0c310bc7.tar.gz
freebsd-ports-gnome-4d264bce95ffcb5f16e7c8663a6eb2ee0c310bc7.tar.zst
freebsd-ports-gnome-4d264bce95ffcb5f16e7c8663a6eb2ee0c310bc7.zip
- New port: Kwiki Gnome Icons Plugin
PR: ports/77737 Submitted by: Mark Foster <mark AT foster dot cc>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Kwiki-Icons-Gnome/Makefile34
-rw-r--r--www/p5-Kwiki-Icons-Gnome/distinfo2
-rw-r--r--www/p5-Kwiki-Icons-Gnome/pkg-descr4
-rw-r--r--www/p5-Kwiki-Icons-Gnome/pkg-message9
-rw-r--r--www/p5-Kwiki-Icons-Gnome/pkg-plist4
6 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 12d66c8768c9..c2adbd421343 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -502,6 +502,7 @@
SUBDIR += p5-Kwiki-Archive-SVK
SUBDIR += p5-Kwiki-Atom
SUBDIR += p5-Kwiki-GDGraphGenerator
+ SUBDIR += p5-Kwiki-Icons-Gnome
SUBDIR += p5-Kwiki-NewPage
SUBDIR += p5-Kwiki-PagePrivacy
SUBDIR += p5-Kwiki-RecentChanges
diff --git a/www/p5-Kwiki-Icons-Gnome/Makefile b/www/p5-Kwiki-Icons-Gnome/Makefile
new file mode 100644
index 000000000000..1c8c1f5208d8
--- /dev/null
+++ b/www/p5-Kwiki-Icons-Gnome/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Kwiki-Icons-Gnome
+# Date created: Feb 16 2005
+# Whom: Mark Foster <mark@foster.cc>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-Icons-Gnome
+PORTVERSION= 0.14
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mark@foster.cc
+COMMENT= Kwiki Gnome Icons plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::Icons::Gnome.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-Icons-Gnome/distinfo b/www/p5-Kwiki-Icons-Gnome/distinfo
new file mode 100644
index 000000000000..f05b1eda9f52
--- /dev/null
+++ b/www/p5-Kwiki-Icons-Gnome/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-Icons-Gnome-0.14.tar.gz) = 12bcd201bd92203ff34855e59ca13ef8
+SIZE (Kwiki-Icons-Gnome-0.14.tar.gz) = 14744
diff --git a/www/p5-Kwiki-Icons-Gnome/pkg-descr b/www/p5-Kwiki-Icons-Gnome/pkg-descr
new file mode 100644
index 000000000000..6c89f667a503
--- /dev/null
+++ b/www/p5-Kwiki-Icons-Gnome/pkg-descr
@@ -0,0 +1,4 @@
+Kwiki::Icons::Gnome - Kwiki Gnome Icons Plugin
+
+WWW: http://cpan.uwinnipeg.ca/dist/Kwiki-Icons-Gnome
+Author: Brian Ingerson <INGY at cpan.org>
diff --git a/www/p5-Kwiki-Icons-Gnome/pkg-message b/www/p5-Kwiki-Icons-Gnome/pkg-message
new file mode 100644
index 000000000000..a078aac409eb
--- /dev/null
+++ b/www/p5-Kwiki-Icons-Gnome/pkg-message
@@ -0,0 +1,9 @@
+/* ================================================================= */
+Note:
+ Kwiki-Icons-Gnome plugin installed! Now you should add
+ to your kwiki in kwiki installation directory:
+
+$ cd cgi-bin/my-kwiki
+$ kwiki -add Kwiki::Icons::Gnome
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-Icons-Gnome/pkg-plist b/www/p5-Kwiki-Icons-Gnome/pkg-plist
new file mode 100644
index 000000000000..7a5b8775a85d
--- /dev/null
+++ b/www/p5-Kwiki-Icons-Gnome/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Kwiki/Icons/Gnome.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Icons/Gnome/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Icons/Gnome
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki/Icons/ 2>/dev/null || true