aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbhughes <bhughes@FreeBSD.org>2019-01-24 05:10:26 +0800
committerbhughes <bhughes@FreeBSD.org>2019-01-24 05:10:26 +0800
commit4ef98ae18be4a3b7414e867752cfe7f37fc2a9aa (patch)
tree3693b81a03f0e632cce7d273d1d93cbd35aa533f /www
parentff0caafc07d4b9a5ca00327169b6d960af6ce41d (diff)
downloadfreebsd-ports-gnome-4ef98ae18be4a3b7414e867752cfe7f37fc2a9aa.tar.gz
freebsd-ports-gnome-4ef98ae18be4a3b7414e867752cfe7f37fc2a9aa.tar.zst
freebsd-ports-gnome-4ef98ae18be4a3b7414e867752cfe7f37fc2a9aa.zip
www/node6: build on FreeBSD >=12
Change the default options to enable BUNDLED_SSL by default on FreeBSD >=12, which includes OpenSSL 1.1 in the base system, not the 1.0.2 required by Node.js 6.x LTS. Bump PORTREVISION due to the change in defaults. While here, convert the port to use BROKEN_SSL, taking care to set BROKEN_SSL+=base when appropriate. Sponsored by: Miles AS
Diffstat (limited to 'www')
-rw-r--r--www/node6/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/www/node6/Makefile b/www/node6/Makefile
index 48581563b506..3275c25768d6 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= node
PORTVERSION= 6.16.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= 6
@@ -13,11 +14,16 @@ COMMENT= V8 JavaScript for client and server (6.x LTS)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_SSL= openssl111 libressl libressl-devel
+BROKEN_SSL_REASON= Node.js 6.x LTS requires OpenSSL 1.0.2 or the BUNDLED_SSL option enabled
ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc64
-OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE
-OPTIONS_DEFAULT=DTRACE
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE
+OPTIONS_DEFAULT= DTRACE
+OPTIONS_DEFAULT_FreeBSD_12= BUNDLED_SSL
+OPTIONS_DEFAULT_FreeBSD_13= BUNDLED_SSL
+OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${OPSYS}_${OSREL:R}}
+OPTIONS_SUB= yes
.if !exists(/usr/sbin/dtrace)
OPTIONS_EXCLUDE+= DTRACE
@@ -61,12 +67,8 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MBUNDLED_SSL)
-
-.if !empty(SSL_DEFAULT:Mlibressl*)
-IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
-.endif
-
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085
+BROKEN_SSL+= base
.endif
.include <bsd.port.pre.mk>