aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2000-12-27 20:55:56 +0800
committertrevor <trevor@FreeBSD.org>2000-12-27 20:55:56 +0800
commit501751153e423d7fd25c0e0a16c4b755c35699a4 (patch)
treef47dd597527fe2268e4c359d70c909cdd0919482 /www
parent33bf046d1b0a26d847d70d1fc2bc4737c0e65697 (diff)
downloadfreebsd-ports-gnome-501751153e423d7fd25c0e0a16c4b755c35699a4.tar.gz
freebsd-ports-gnome-501751153e423d7fd25c0e0a16c4b755c35699a4.tar.zst
freebsd-ports-gnome-501751153e423d7fd25c0e0a16c4b755c35699a4.zip
Correct breakage caused by my hasty addition of DIST_SUBDIR. Add
dependency on archivers/unzip. Thanks to Kevin Lo for reporting both problems. Also, reassure users about a harmless error.
Diffstat (limited to 'www')
-rw-r--r--www/linux-netscape6/Makefile4
-rw-r--r--www/linux-netscape6/distinfo2
-rw-r--r--www/netscape7/Makefile4
-rw-r--r--www/netscape7/distinfo2
4 files changed, 8 insertions, 4 deletions
diff --git a/www/linux-netscape6/Makefile b/www/linux-netscape6/Makefile
index 3c20890da6fb..395856811dd2 100644
--- a/www/linux-netscape6/Makefile
+++ b/www/linux-netscape6/Makefile
@@ -28,6 +28,7 @@ DIST_SUBDIR= netscape6/english/${PORTVERSION}
MAINTAINER= trevor@FreeBSD.org
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= ${LINUX_BASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
${LINUX_BASE}/usr/lib/libgtk-1.2.so.0.5.0:${PORTSDIR}/x11-toolkits/linux-gtk \
${LINUX_BASE}/usr/lib/libjpeg.so.62.0.0:${PORTSDIR}/graphics/linux-jpeg
@@ -45,7 +46,7 @@ STARTUP_CMD= netscape6
do-extract:
${MKDIR} ${WRKSRC}
- @${TAR} xzf ${DISTDIR}/${DISTFILES} -C ${WRKDIR}
+ @${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} -C ${WRKDIR}
.for i in browser deflenus jre langenus mail psm spellchecker xpcom
unzip -qo ${WRKSRC}/${i}.xpi -d ${WRKSRC}
.endfor
@@ -63,6 +64,7 @@ do-patch:
do-configure:
${SETENV} $DISPLAY="NONE" ${WRKSRC}/bin/netscape file:///dev/null
+ @${ECHO} A \"cannot open display\" error here is normal.
${SED} -e "s;%%INSTALL_DIR%%;${INSTALL_DIR};g" \
${FILESDIR}/start.sh >${WRKDIR}/${STARTUP_CMD}
diff --git a/www/linux-netscape6/distinfo b/www/linux-netscape6/distinfo
index 61a7aa125a32..7ea2ef80303b 100644
--- a/www/linux-netscape6/distinfo
+++ b/www/linux-netscape6/distinfo
@@ -1 +1 @@
-MD5 (netscape-i686-pc-linux-gnu-sea.tar.gz) = 8ed6dd0c331153dc95c0e72bc098ff3b
+MD5 (netscape6/english/6.0/netscape-i686-pc-linux-gnu-sea.tar.gz) = 8ed6dd0c331153dc95c0e72bc098ff3b
diff --git a/www/netscape7/Makefile b/www/netscape7/Makefile
index 3c20890da6fb..395856811dd2 100644
--- a/www/netscape7/Makefile
+++ b/www/netscape7/Makefile
@@ -28,6 +28,7 @@ DIST_SUBDIR= netscape6/english/${PORTVERSION}
MAINTAINER= trevor@FreeBSD.org
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= ${LINUX_BASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
${LINUX_BASE}/usr/lib/libgtk-1.2.so.0.5.0:${PORTSDIR}/x11-toolkits/linux-gtk \
${LINUX_BASE}/usr/lib/libjpeg.so.62.0.0:${PORTSDIR}/graphics/linux-jpeg
@@ -45,7 +46,7 @@ STARTUP_CMD= netscape6
do-extract:
${MKDIR} ${WRKSRC}
- @${TAR} xzf ${DISTDIR}/${DISTFILES} -C ${WRKDIR}
+ @${TAR} xzf ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} -C ${WRKDIR}
.for i in browser deflenus jre langenus mail psm spellchecker xpcom
unzip -qo ${WRKSRC}/${i}.xpi -d ${WRKSRC}
.endfor
@@ -63,6 +64,7 @@ do-patch:
do-configure:
${SETENV} $DISPLAY="NONE" ${WRKSRC}/bin/netscape file:///dev/null
+ @${ECHO} A \"cannot open display\" error here is normal.
${SED} -e "s;%%INSTALL_DIR%%;${INSTALL_DIR};g" \
${FILESDIR}/start.sh >${WRKDIR}/${STARTUP_CMD}
diff --git a/www/netscape7/distinfo b/www/netscape7/distinfo
index 61a7aa125a32..7ea2ef80303b 100644
--- a/www/netscape7/distinfo
+++ b/www/netscape7/distinfo
@@ -1 +1 @@
-MD5 (netscape-i686-pc-linux-gnu-sea.tar.gz) = 8ed6dd0c331153dc95c0e72bc098ff3b
+MD5 (netscape6/english/6.0/netscape-i686-pc-linux-gnu-sea.tar.gz) = 8ed6dd0c331153dc95c0e72bc098ff3b