aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerSatoshi Asami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commit5114e2637e2224ea9b0e0ea4b315bc38370ccf04 (patch)
tree414dd9b31f0192eb7d0054b2463c2eed8afd25b4 /www
parentfd5131ad95770d2ae6bee7059204950dfa6402d1 (diff)
downloadfreebsd-ports-gnome-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.tar.gz
freebsd-ports-gnome-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.tar.zst
freebsd-ports-gnome-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'www')
-rw-r--r--www/apache13-fp/Makefile4
-rw-r--r--www/htmlpp/Makefile5
-rw-r--r--www/netscape4-navigator/Makefile4
3 files changed, 7 insertions, 6 deletions
diff --git a/www/apache13-fp/Makefile b/www/apache13-fp/Makefile
index 3642dcbf976f..4ad13398d1a4 100644
--- a/www/apache13-fp/Makefile
+++ b/www/apache13-fp/Makefile
@@ -3,7 +3,7 @@
# Date created: Sat Oct 31 16:30:00 CDT 1997
# Whom: hetzels@westbend.net
#
-# $Id: Makefile,v 1.6 1998/12/02 00:32:38 obrien Exp $
+# $Id: Makefile,v 1.7 1999/01/26 02:27:26 steve Exp $
#
DISTNAME= apache_${AP_VERS}
@@ -108,7 +108,7 @@ pre-extract:
post-extract:
@${ECHO} "===> Extracting FrontPage install scripts"
@cd ${WRKSRC} && \
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${FPINSTALL} ${CHANGESERVER}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${EXTRACT_AFTER_ARGS} ${FPINSTALL} ${CHANGESERVER}
post-install:
@${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh file."
diff --git a/www/htmlpp/Makefile b/www/htmlpp/Makefile
index 27336d843c96..38521400c8c9 100644
--- a/www/htmlpp/Makefile
+++ b/www/htmlpp/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 Nov 1997
# Whom: Donald Burr <dburr@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.2 1998/09/15 21:31:55 asami Exp $
+# $Id: Makefile,v 1.3 1998/11/29 08:20:30 asami Exp $
#
DISTNAME= htmlpp
@@ -17,7 +17,8 @@ MAINTAINER= dburr@FreeBSD.ORG
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
EXTRACT_CMD= unzip
-EXTRACT_ARGS= -qa
+EXTRACT_BEFORE_ARGS= -qa
+EXTRACT_AFTER_ARGS= # empty
USE_PERL5= YES
diff --git a/www/netscape4-navigator/Makefile b/www/netscape4-navigator/Makefile
index fc4c78fdd983..bf339a5c6674 100644
--- a/www/netscape4-navigator/Makefile
+++ b/www/netscape4-navigator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: ache
#
-# $Id: Makefile,v 1.35 1999/01/06 04:18:14 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/13 04:00:09 scrappy Exp $
#
DISTNAME= netscape-navigator-4.08
@@ -49,7 +49,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.jar ${NDIR}/java/classes
${INSTALL_PROGRAM} ${WRKSRC}/vreg ${NDIR}
for i in ${WRKSRC}/*.nif; do \
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} -C ${NDIR}; \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} ${EXTRACT_AFTER_ARGS} -C ${NDIR}; \
done
${WRKSRC}/vreg ${NDIR}/registry ${WRKSRC}/infile
${MV} -f ${NDIR}/netscape ${NDIR}/navigator-4.08.bin