aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-06 01:56:58 +0800
committerpav <pav@FreeBSD.org>2004-07-06 01:56:58 +0800
commit511a728ce6ecf6d5d8c2f567a5b9535b2a1ad7a2 (patch)
tree4b75499e8c4c8e49019e129390a5e4e7527adeda /www
parent93174fd9ba45612694202d58e8523e41adfbf574 (diff)
downloadfreebsd-ports-gnome-511a728ce6ecf6d5d8c2f567a5b9535b2a1ad7a2.tar.gz
freebsd-ports-gnome-511a728ce6ecf6d5d8c2f567a5b9535b2a1ad7a2.tar.zst
freebsd-ports-gnome-511a728ce6ecf6d5d8c2f567a5b9535b2a1ad7a2.zip
Add zope-i18nlayer, a Zope product that provides a transparent overlay
above multiple content objects to provide multilanguage content support for existing document types. PR: ports/68652 Submitted by: Khairil Yusof <kaeru@inigo-tech.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/zope-i18nlayer/Makefile60
-rw-r--r--www/zope-i18nlayer/distinfo2
-rw-r--r--www/zope-i18nlayer/pkg-descr9
-rw-r--r--www/zope-i18nlayer/pkg-message24
5 files changed, 96 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d0d3801858b2..08a22204a60a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -682,6 +682,7 @@
SUBDIR += zope-formulator
SUBDIR += zope-groupuserfolder
SUBDIR += zope-guf
+ SUBDIR += zope-i18nlayer
SUBDIR += zope-mindmapbbs
SUBDIR += zope-parsedxml
SUBDIR += zope-placelesstranslationservice
diff --git a/www/zope-i18nlayer/Makefile b/www/zope-i18nlayer/Makefile
new file mode 100644
index 000000000000..7a386d2a4da0
--- /dev/null
+++ b/www/zope-i18nlayer/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: zope-i18nlayer
+# Date created: July 4 2004
+# Whom: Khairil Yusof <kaeru@inigo-tech.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= i18nlayer
+PORTVERSION= 0.5.5
+CATEGORIES= www zope
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= collective
+PKGNAMEPREFIX= zope-
+DISTNAME= I18NLayer-${PORTVERSION}
+
+MAINTAINER= kaeru@inigo-tech.com
+COMMENT= I18NLayer product for Zope
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/CMFPlone/__init__.py:${PORTSDIR}/www/plone \
+ ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/Archetypes/__init__.py:${PORTSDIR}/www/zope-archetypes \
+ ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/PlacelessTranslationService/__init__.py:${PORTSDIR}/www/zope-placelesstranslationservice
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+EXTRACT_CMD= tar
+EXTRACT_BEFORE_ARGS= -zxvf
+EXTRACT_AFTER_ARGS= --exclude CVS
+
+ZOPEPRODUCTNAME= I18NLayer
+
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -x skins ${WRKSRC}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${TOUCH} ${PLIST}
+ @cd ${WRKDIR} && \
+ for f in `${FIND} ${ZOPEPRODUCTNAME} -type f`; do \
+ ${ECHO_CMD} %%ZOPEPRODUCTDIR%%/$${f} >> ${PLIST}; \
+ done; \
+ for d in `${FIND} -d ${ZOPEPRODUCTNAME} -type d`; do \
+ ${ECHO_CMD} @dirrm %%ZOPEPRODUCTDIR%%/$${d} >> ${PLIST}; \
+ done; \
+
+do-install:
+ @${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+ @${CHMOD} -R og+rX ${WRKSRC}/
+ @${CP} -R ${WRKSRC} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-i18nlayer/distinfo b/www/zope-i18nlayer/distinfo
new file mode 100644
index 000000000000..e984b6269d84
--- /dev/null
+++ b/www/zope-i18nlayer/distinfo
@@ -0,0 +1,2 @@
+MD5 (zope/I18NLayer-0.5.5.tar.gz) = c665c8dc212c3bd36a62df57fd60994d
+SIZE (zope/I18NLayer-0.5.5.tar.gz) = 31941
diff --git a/www/zope-i18nlayer/pkg-descr b/www/zope-i18nlayer/pkg-descr
new file mode 100644
index 000000000000..caa63b10e735
--- /dev/null
+++ b/www/zope-i18nlayer/pkg-descr
@@ -0,0 +1,9 @@
+I18NLayer is a product for Zope
+
+I18NLayer provides a transparent overlay above multiple content objects to
+provide multilanguage content support for existing document types.
+
+WWW: http://plone.org/collective
+
+- Khairil Yusof
+kaeru@inigo-tech.com
diff --git a/www/zope-i18nlayer/pkg-message b/www/zope-i18nlayer/pkg-message
new file mode 100644
index 000000000000..d3abfaa96d93
--- /dev/null
+++ b/www/zope-i18nlayer/pkg-message
@@ -0,0 +1,24 @@
+To complete the installation of I18NLayer:
+
+- Restart Zope. This may be done from the Zope Control Panel.
+
+With CMFQuickInstaller (optional)
+
+- Use the QuickInstaller tool to register I18NLayer in your portal
+ instance
+
+With Plone (optional)
+
+- Use Plone Setup, to install I18NLayer product.
+
+Without CMFQuickInstaller
+
+ - Create an ExternalMethod object inside your portal object with the
+ following data:
+
+ Id: install_I18NLayer
+ Title: installs I18NLayer to this portal
+ Module Name: I18NLayer.Install
+ Function Name: install
+
+ - Run this newly created ExternalMethod by clicking on the test tab.