aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-05 06:05:19 +0800
committeryuri <yuri@FreeBSD.org>2018-03-05 06:05:19 +0800
commit51357499edcedc4fd0dd715caae1d111aa3f272f (patch)
treef69d11756234c70521de13861bbf27621dca0b4c /www
parent35a07d62c6509fcb4f72597ed460ffb2d4de7e2c (diff)
downloadfreebsd-ports-gnome-51357499edcedc4fd0dd715caae1d111aa3f272f.tar.gz
freebsd-ports-gnome-51357499edcedc4fd0dd715caae1d111aa3f272f.tar.zst
freebsd-ports-gnome-51357499edcedc4fd0dd715caae1d111aa3f272f.zip
New port: www/py-sseclient: Python client library for reading Server Sent Event streams
Approved by: tcberner (mentor, implicit)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-sseclient/Makefile21
-rw-r--r--www/py-sseclient/distinfo3
-rw-r--r--www/py-sseclient/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8bdaeb8c4222..be321baef13d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1867,6 +1867,7 @@
SUBDIR += py-sockjs-tornado
SUBDIR += py-splinter
SUBDIR += py-spyne
+ SUBDIR += py-sseclient
SUBDIR += py-surl
SUBDIR += py-textile
SUBDIR += py-tmdb3
diff --git a/www/py-sseclient/Makefile b/www/py-sseclient/Makefile
new file mode 100644
index 000000000000..8d55efaa972a
--- /dev/null
+++ b/www/py-sseclient/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= sseclient
+DISTVERSION= 0.0.18
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python client library for reading Server Sent Event streams
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-sseclient/distinfo b/www/py-sseclient/distinfo
new file mode 100644
index 000000000000..67825aa714f4
--- /dev/null
+++ b/www/py-sseclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520200425
+SHA256 (sseclient-0.0.18.tar.gz) = 1760af17b8c35d815a908040e6f9258f7c531c7522ce08f6112ffe99711e2ed9
+SIZE (sseclient-0.0.18.tar.gz) = 4402
diff --git a/www/py-sseclient/pkg-descr b/www/py-sseclient/pkg-descr
new file mode 100644
index 000000000000..4db4134135e6
--- /dev/null
+++ b/www/py-sseclient/pkg-descr
@@ -0,0 +1,6 @@
+A Python client library for iterating over http Server Sent Event (SSE) streams
+(also known as EventSource, after the name of the Javascript interface inside
+browsers). The SSEClient class accepts a url on init, and is then an iterator
+over messages coming from the server.
+
+WWW: https://github.com/btubbs/sseclient