aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-07-09 11:19:18 +0800
committeravilla <avilla@FreeBSD.org>2012-07-09 11:19:18 +0800
commit51cd02fa964d987d513f787fb416de34a50bf7e7 (patch)
tree727c9cccbac27a67ff2f266defcd801f299ce1a9 /www
parent4a9a072575f15550db4cf339b4c88e1ffcf9b522 (diff)
downloadfreebsd-ports-gnome-51cd02fa964d987d513f787fb416de34a50bf7e7.tar.gz
freebsd-ports-gnome-51cd02fa964d987d513f787fb416de34a50bf7e7.tar.zst
freebsd-ports-gnome-51cd02fa964d987d513f787fb416de34a50bf7e7.zip
KParts Plugin implements a plugin for Netscape-compatible browsers in
Unix environments. This plugin uses KDE KParts technology to embed file viewers (e.g., for PDF files) into non-KDE browsers. Tested browsers include both Mozilla Firefox and Opera, and it is know to work with Chrome and Arora. With this plugin, you can, e.g., view PDF files in Firefox using Okular as an embedded plugin. Any KDE KPart will be automatically made available as a browser plugin. WWW: http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/kpartsplugin/Makefile26
-rw-r--r--www/kpartsplugin/distinfo2
-rw-r--r--www/kpartsplugin/pkg-descr11
-rw-r--r--www/kpartsplugin/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b86eafe5e679..7554300dd816 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -378,6 +378,7 @@
SUBDIR += kdewebdev4
SUBDIR += khtml2png
SUBDIR += kompozer
+ SUBDIR += kpartsplugin
SUBDIR += kplaylist
SUBDIR += kwebkitpart
SUBDIR += larbin
diff --git a/www/kpartsplugin/Makefile b/www/kpartsplugin/Makefile
new file mode 100644
index 000000000000..d3104e094481
--- /dev/null
+++ b/www/kpartsplugin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection Makefile for: kpartsplugin
+# Date created: 9 July 2012
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kpartsplugin
+DISTVERSION= 0.0-${PORTDATE}
+CATEGORIES= www kde
+MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${PORTDATE}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Browser file viewer using KDE technology
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_QT4= gui moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DNSPLUGIN_INSTALL_DIR:PATH="${LOCALBASE}/mozilla/plugins"
+MAKE_JOBS_SAFE= yes
+
+PORTDATE= 20120605
+
+.include <bsd.port.mk>
diff --git a/www/kpartsplugin/distinfo b/www/kpartsplugin/distinfo
new file mode 100644
index 000000000000..070e2442e02e
--- /dev/null
+++ b/www/kpartsplugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kpartsplugin-20120605.tar.bz2) = 2d4fef7efcd661c0dfab8f383b98b279ff8c296acf6fae4e9dc16da4e30e6da4
+SIZE (kpartsplugin-20120605.tar.bz2) = 34733
diff --git a/www/kpartsplugin/pkg-descr b/www/kpartsplugin/pkg-descr
new file mode 100644
index 000000000000..b5849d03c844
--- /dev/null
+++ b/www/kpartsplugin/pkg-descr
@@ -0,0 +1,11 @@
+KParts Plugin implements a plugin for Netscape-compatible browsers in
+Unix environments. This plugin uses KDE KParts technology to embed
+file viewers (e.g., for PDF files) into non-KDE browsers. Tested
+browsers include both Mozilla Firefox and Opera, and it is know to
+work with Chrome and Arora.
+
+With this plugin, you can, e.g., view PDF files in Firefox using
+Okular as an embedded plugin. Any KDE KPart will be automatically made
+available as a browser plugin.
+
+WWW: http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin
diff --git a/www/kpartsplugin/pkg-plist b/www/kpartsplugin/pkg-plist
new file mode 100644
index 000000000000..25ceec581da3
--- /dev/null
+++ b/www/kpartsplugin/pkg-plist
@@ -0,0 +1,6 @@
+lib/kde4/kcm_kpartsplugin.so
+share/kde4/services/kcm_kpartsplugin.desktop
+@cwd %%LOCALBASE%%
+mozilla/plugins/libkpartsplugin.so
+@dirrmtry mozilla/plugins
+@dirrmtry mozilla