aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-10-15 00:17:40 +0800
committerclsung <clsung@FreeBSD.org>2004-10-15 00:17:40 +0800
commit5354190572a0c2f3de15c9e4b5cae27ccab120dd (patch)
treedf32a3cd54667e414da4148e891cf39c76609a78 /www
parent80543ec24c1f3ee9a61cadc4409980676bc3bba1 (diff)
downloadfreebsd-ports-gnome-5354190572a0c2f3de15c9e4b5cae27ccab120dd.tar.gz
freebsd-ports-gnome-5354190572a0c2f3de15c9e4b5cae27ccab120dd.tar.zst
freebsd-ports-gnome-5354190572a0c2f3de15c9e4b5cae27ccab120dd.zip
- p5-libapreq2 has been committed by kuriyama.
- apply kuriyama's modified patch to www/p5-MasonX-Apche2Handler. PR: ports/72037 Submitted by: maintainer (Autrijus Tang <autrijus AT not.autrijus dot org>) Reviewed by: kuriyama Approved by: co-mentor (vanilla)
Diffstat (limited to 'www')
-rw-r--r--www/p5-MasonX-Apache2Handler/Makefile7
-rw-r--r--www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL12
-rw-r--r--www/p5-MasonX-Apache2Handler/files/patch-lib-MasonX-Apache2Handler.pm11
3 files changed, 28 insertions, 2 deletions
diff --git a/www/p5-MasonX-Apache2Handler/Makefile b/www/p5-MasonX-Apache2Handler/Makefile
index 44f2bad52127..1c7fdf8ce7a4 100644
--- a/www/p5-MasonX-Apache2Handler/Makefile
+++ b/www/p5-MasonX-Apache2Handler/Makefile
@@ -7,6 +7,7 @@
PORTNAME= MasonX-Apache2Handler
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= MasonX
@@ -15,14 +16,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= autrijus@autrijus.org
COMMENT= Mason/mod_perl2 interface
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2:${PORTSDIR}/www/mod_perl2 \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/ModPerl/Config.pm:${PORTSDIR}/www/mod_perl2 \
${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq2 \
${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
-
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= MasonX::Apache2Handler.3 MasonX::Mason-with-mod_perl2.3
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM}
+
.include <bsd.port.mk>
diff --git a/www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL b/www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL
new file mode 100644
index 000000000000..47aa3202ff99
--- /dev/null
+++ b/www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig Thu Sep 23 18:16:48 2004
++++ Makefile.PL Thu Sep 23 18:17:14 2004
+@@ -14,6 +14,9 @@
+ *EOF*
+ sleep 3;
+
++# Detect PREREQ_PM if they are installed in Apache2/.
++eval { require Apache2 };
++
+ WriteMakefile(
+ NAME => 'MasonX::Apache2Handler',
+ VERSION_FROM => 'lib/MasonX/Apache2Handler.pm', # finds $VERSION
diff --git a/www/p5-MasonX-Apache2Handler/files/patch-lib-MasonX-Apache2Handler.pm b/www/p5-MasonX-Apache2Handler/files/patch-lib-MasonX-Apache2Handler.pm
new file mode 100644
index 000000000000..447a25380765
--- /dev/null
+++ b/www/p5-MasonX-Apache2Handler/files/patch-lib-MasonX-Apache2Handler.pm
@@ -0,0 +1,11 @@
+--- lib/MasonX/Apache2Handler.pm Thu Sep 23 17:26:41 2004
++++ lib/MasonX/Apache2Handler.pm Thu Sep 23 17:26:54 2004
+@@ -615,7 +615,7 @@
+ if (exists $allowed_params->{data_dir} and not exists $params{data_dir})
+ {
+ # constructs path to <server root>/mason
+- my $def = $defaults{data_dir} = Apache->server->server_root_relative('mason');
++ my $def = $defaults{data_dir} = File::Spec->catfile(Apache::ServerUtil::server_root(), 'mason');
+ param_error "Default data_dir (MasonDataDir) '$def' must be an absolute path"
+ unless File::Spec->file_name_is_absolute($def);
+