aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-29 08:30:04 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-29 08:30:04 +0800
commit54779474e5429f0c603df4bad1f89fbd2b626758 (patch)
tree2765968e1694aecdaa42d7303a88cabcad6e4bd8 /www
parentc7979e86469e278252c2b2ef8308906afdabb88b (diff)
downloadfreebsd-ports-gnome-54779474e5429f0c603df4bad1f89fbd2b626758.tar.gz
freebsd-ports-gnome-54779474e5429f0c603df4bad1f89fbd2b626758.tar.zst
freebsd-ports-gnome-54779474e5429f0c603df4bad1f89fbd2b626758.zip
Add p5-Template-Plugin-Monta.
Template::Plugin::Monta is a plugin for Template Toolkit which allows you to use monta-method on your template. WWW: http://search.cpan.org/dist/Template-Plugin-Monta/ PR: ports/82632 Submitted by: TAKAHASHI Kaoru <kaoru@kaisei.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Plugin-Monta/Makefile32
-rw-r--r--www/p5-Template-Plugin-Monta/distinfo2
-rw-r--r--www/p5-Template-Plugin-Monta/pkg-descr4
-rw-r--r--www/p5-Template-Plugin-Monta/pkg-plist6
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8c964af2f670..25a7b3c1d9b4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -587,6 +587,7 @@
SUBDIR += p5-Template-Plugin-Class
SUBDIR += p5-Template-Plugin-Comma
SUBDIR += p5-Template-Plugin-MP3
+ SUBDIR += p5-Template-Plugin-Monta
SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
diff --git a/www/p5-Template-Plugin-Monta/Makefile b/www/p5-Template-Plugin-Monta/Makefile
new file mode 100644
index 000000000000..8411daed145e
--- /dev/null
+++ b/www/p5-Template-Plugin-Monta/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Template-Plugin-Monta
+# Date created: 14 June 2005
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-Monta
+PORTVERSION= 0.03
+CATEGORIES= www textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Template-Toolkit plugin to Monta Method
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${SITE_PERL}/${PERL_ARCH}/Acme/Monta.pm:${PORTSDIR}/www/p5-Acme-Monta
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Plugin::Monta.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or greater. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Plugin-Monta/distinfo b/www/p5-Template-Plugin-Monta/distinfo
new file mode 100644
index 000000000000..08f0561069b7
--- /dev/null
+++ b/www/p5-Template-Plugin-Monta/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Plugin-Monta-0.03.tar.gz) = 7a88b986dae29b66d9aaa76ac0a83a44
+SIZE (Template-Plugin-Monta-0.03.tar.gz) = 1972
diff --git a/www/p5-Template-Plugin-Monta/pkg-descr b/www/p5-Template-Plugin-Monta/pkg-descr
new file mode 100644
index 000000000000..d932664fb2d3
--- /dev/null
+++ b/www/p5-Template-Plugin-Monta/pkg-descr
@@ -0,0 +1,4 @@
+Template::Plugin::Monta is a plugin for Template Toolkit which allows you to
+use monta-method on your template.
+
+WWW: http://search.cpan.org/dist/Template-Plugin-Monta/
diff --git a/www/p5-Template-Plugin-Monta/pkg-plist b/www/p5-Template-Plugin-Monta/pkg-plist
new file mode 100644
index 000000000000..840c59aa1c4f
--- /dev/null
+++ b/www/p5-Template-Plugin-Monta/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Monta/.packlist
+%%SITE_PERL%%/Template/Plugin/Monta.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Monta
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Template/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true