aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-01-31 03:21:46 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-01-31 03:21:46 +0800
commit558c625453d8a4871ac053f2fe3de84e63919226 (patch)
tree6c652330792e03e63a6a01d660ac9c01321ce8f2 /www
parent9ea2d6166f92d6bbb85fec845c156eb95eddbcaa (diff)
downloadfreebsd-ports-gnome-558c625453d8a4871ac053f2fe3de84e63919226.tar.gz
freebsd-ports-gnome-558c625453d8a4871ac053f2fe3de84e63919226.tar.zst
freebsd-ports-gnome-558c625453d8a4871ac053f2fe3de84e63919226.zip
Add py-wagtail 2.4
Wagtail is an open source content management system built on Django, with a strong community and commercial support. It's focused on user experience, and offers precise control for designers and developers. WWW: https://wagtail.io/ WWW: https://github.com/wagtail/wagtail
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-wagtail/Makefile38
-rw-r--r--www/py-wagtail/distinfo3
-rw-r--r--www/py-wagtail/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 948ae11fe11a..ff2d3e71b19a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1869,6 +1869,7 @@
SUBDIR += py-user_agent
SUBDIR += py-utidylib
SUBDIR += py-w3lib
+ SUBDIR += py-wagtail
SUBDIR += py-waitress
SUBDIR += py-webassets
SUBDIR += py-webhelpers
diff --git a/www/py-wagtail/Makefile b/www/py-wagtail/Makefile
new file mode 100644
index 000000000000..bbad765500c3
--- /dev/null
+++ b/www/py-wagtail/Makefile
@@ -0,0 +1,38 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wagtail
+PORTVERSION= 2.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Django content management system
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.1:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-modelcluster>=4.2:www/py-django-modelcluster@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-taggit>=0.23:www/py-django-taggit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-treebeard>=4.2.0:www/py-django-treebeard@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django111>=1.11:www/py-django111@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}djangorestframework>=3.7.4:www/py-djangorestframework@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}draftjs_exporter>=2.1.5:www/py-draftjs_exporter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>=0.999:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=4.0.0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2016.6:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.11.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.11:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04.14:converters/py-unidecode@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}willow>=1.1:graphics/py-willow@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+SHEBANG_FILES= wagtail/project_template/manage.py
+
+.include <bsd.port.mk>
diff --git a/www/py-wagtail/distinfo b/www/py-wagtail/distinfo
new file mode 100644
index 000000000000..8abbb0bbfe91
--- /dev/null
+++ b/www/py-wagtail/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546725026
+SHA256 (wagtail-2.4.tar.gz) = 1dd069ef8b3a08728fa5304e45ee2a92ed49b8e235e9c8b677adfd2039cff1fd
+SIZE (wagtail-2.4.tar.gz) = 7753917
diff --git a/www/py-wagtail/pkg-descr b/www/py-wagtail/pkg-descr
new file mode 100644
index 000000000000..d06e5be1d164
--- /dev/null
+++ b/www/py-wagtail/pkg-descr
@@ -0,0 +1,6 @@
+Wagtail is an open source content management system built on Django, with a
+strong community and commercial support. It's focused on user experience, and
+offers precise control for designers and developers.
+
+WWW: https://wagtail.io/
+WWW: https://github.com/wagtail/wagtail