aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-02-19 08:33:47 +0800
committerjbeich <jbeich@FreeBSD.org>2019-02-19 08:33:47 +0800
commit57e46fb454072f579321c41a9f89a0b18c60c8b1 (patch)
treea53a76810dd67dcf82999d660206220b73dada94 /www
parent503679e5ea8fa7b49908992eb1d5b3bb596df78a (diff)
downloadfreebsd-ports-gnome-57e46fb454072f579321c41a9f89a0b18c60c8b1.tar.gz
freebsd-ports-gnome-57e46fb454072f579321c41a9f89a0b18c60c8b1.tar.zst
freebsd-ports-gnome-57e46fb454072f579321c41a9f89a0b18c60c8b1.zip
www/firefox: add one more Wayland+WebRender fix
Obtained from: upstream (Firefox 67)
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-bug152755631
2 files changed, 32 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index b7d8ba1b97de..cc33257ea1ef 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 65.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1527556 b/www/firefox/files/patch-bug1527556
new file mode 100644
index 000000000000..2ce53c082cef
--- /dev/null
+++ b/www/firefox/files/patch-bug1527556
@@ -0,0 +1,31 @@
+commit ba954951557e
+Author: sotaro <sotaro.ikeda.g@gmail.com>
+Date: Mon Feb 18 09:15:30 2019 +0000
+
+ Bug 1527556 - Change MAX_DISPLAY_CONNECTIONS to 3 r=stransky
+
+ nsWaylandDisplay needs to be allocated for each calling thread(main thread, compositor thread and render thread)
+
+ Differential Revision: https://phabricator.services.mozilla.com/D20118
+
+ --HG--
+ extra : moz-landing-system : lando
+---
+ widget/gtk/nsWaylandDisplay.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git widget/gtk/nsWaylandDisplay.cpp widget/gtk/nsWaylandDisplay.cpp
+index 4c2804be2831..ac01e1f50347 100644
+--- widget/gtk/nsWaylandDisplay.cpp
++++ widget/gtk/nsWaylandDisplay.cpp
+@@ -14,7 +14,9 @@
+ namespace mozilla {
+ namespace widget {
+
+-#define MAX_DISPLAY_CONNECTIONS 2
++// nsWaylandDisplay needs to be created for each calling thread(main thread,
++// compositor thread and render thread)
++#define MAX_DISPLAY_CONNECTIONS 3
+
+ static nsWaylandDisplay *gWaylandDisplays[MAX_DISPLAY_CONNECTIONS];
+ static StaticMutex gWaylandDisplaysMutex;