aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-03-04 07:44:37 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 19:57:27 +0800
commit5a3578ea01cdb0c58e821802f3788bb2d6335696 (patch)
tree53dea87eb7407de8300efb34aa3204e72fe23b7b /www
parent38ae3bb130742a6a0cfea1ac9c217fc85f924760 (diff)
downloadfreebsd-ports-gnome-5a3578ea01cdb0c58e821802f3788bb2d6335696.tar.gz
freebsd-ports-gnome-5a3578ea01cdb0c58e821802f3788bb2d6335696.tar.zst
freebsd-ports-gnome-5a3578ea01cdb0c58e821802f3788bb2d6335696.zip
www/firefox: attempt to unbreak wifi geo and safebrowsing since 51.0
MFH: 2017Q1 (requires r434999 to avoid patch conflict)
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-env-api-keys21
2 files changed, 22 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4cb2929436e4..95587636fd85 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-env-api-keys b/www/firefox/files/patch-env-api-keys
new file mode 100644
index 000000000000..e20b012f27cf
--- /dev/null
+++ b/www/firefox/files/patch-env-api-keys
@@ -0,0 +1,21 @@
+# Accept API keys from environment like before bug 1294585
+
+--- build/moz.configure/keyfiles.configure
++++ build/moz.configure/keyfiles.configure
+@@ -18,6 +18,7 @@ def keyfile(desc, help=None, callback=lambda x: x):
+ @checking('for the %s key' % desc, lambda x: x and x is not no_key)
+ @imports(_from='__builtin__', _import='open')
+ @imports(_from='__builtin__', _import='IOError')
++ @imports(_from='os', _import='environ')
+ def keyfile(value):
+ if value:
+ try:
+@@ -28,7 +29,7 @@ def keyfile(desc, help=None, callback=lambda x: x):
+ raise FatalCheckError("'%s' is empty." % value[0])
+ except IOError as e:
+ raise FatalCheckError("'%s': %s." % (value[0], e.strerror))
+- return no_key
++ return environ.get('MOZ_%s_KEY' % desc.upper().replace(' ', '_')) or no_key
+
+ return keyfile
+