aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-07-21 22:28:03 +0800
committerkrion <krion@FreeBSD.org>2003-07-21 22:28:03 +0800
commit5b38028e69ef950684838e4811e824fbc2633a8a (patch)
tree91fe01a0aca394196f49459302d38e4b5430d429 /www
parent8d350e52b848599406f1034602cf6fef67a1e43c (diff)
downloadfreebsd-ports-gnome-5b38028e69ef950684838e4811e824fbc2633a8a.tar.gz
freebsd-ports-gnome-5b38028e69ef950684838e4811e824fbc2633a8a.tar.zst
freebsd-ports-gnome-5b38028e69ef950684838e4811e824fbc2633a8a.zip
ffproxy is a filtering HTTP proxy server. It is able
to filter by host, URL, and header. Custom header entries can be filtered and added. It can even drop its privileges and optionally chroot() to some directory. Logging to syslog() is supported, as is using another auxiliary proxy server. Contacting IPv6 servers is supported and allows transparent IPv6 over IPv4 browsing. PR: 54669 Approved by: fjoe (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/ffproxy/Makefile33
-rw-r--r--www/ffproxy/distinfo1
-rw-r--r--www/ffproxy/files/patch-Makefile13
-rw-r--r--www/ffproxy/files/patch-dbs.h7
-rw-r--r--www/ffproxy/pkg-descr9
-rw-r--r--www/ffproxy/pkg-plist24
7 files changed, 88 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e91b553098bd..399594a40de7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -80,6 +80,7 @@
SUBDIR += erwn
SUBDIR += evg
SUBDIR += fcgi
+ SUBDIR += ffproxy
SUBDIR += fhttpd
SUBDIR += flashplugin
SUBDIR += flashplugin-mozilla
diff --git a/www/ffproxy/Makefile b/www/ffproxy/Makefile
new file mode 100644
index 000000000000..c69faf8565a8
--- /dev/null
+++ b/www/ffproxy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ffproxy
+# Date created: Jul 20 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffproxy
+PORTVERSION= 1.4
+CATEGORIES= www
+MASTER_SITES= http://faith.eu.org/${PORTNAME}/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Filtering HTTP proxy server
+
+MAN8= ${PORTNAME}.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 \
+ ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/sample.config \
+ ${PREFIX}/etc/ffproxy.conf.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/db
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/db/* ${DOCSDIR}/db
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/ffproxy/distinfo b/www/ffproxy/distinfo
new file mode 100644
index 000000000000..36e89fe71409
--- /dev/null
+++ b/www/ffproxy/distinfo
@@ -0,0 +1 @@
+MD5 (ffproxy-1.4.tar.gz) = 1fb5e67a284395421419dab3a982e648
diff --git a/www/ffproxy/files/patch-Makefile b/www/ffproxy/files/patch-Makefile
new file mode 100644
index 000000000000..d191fa847c3a
--- /dev/null
+++ b/www/ffproxy/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Sun Jul 20 19:17:45 2003
++++ Makefile Sun Jul 20 19:19:10 2003
+@@ -12,8 +12,8 @@
+
+ MANPAGES = ffproxy.8
+
+-PREFIX = /usr/local
+-CC = gcc
++PREFIX = ${PREFIX}
++CC ?= gcc
+
+ all: proxy
+
diff --git a/www/ffproxy/files/patch-dbs.h b/www/ffproxy/files/patch-dbs.h
new file mode 100644
index 000000000000..d293090a53ff
--- /dev/null
+++ b/www/ffproxy/files/patch-dbs.h
@@ -0,0 +1,7 @@
+--- dbs.h.orig Sun Jul 20 19:16:32 2003
++++ dbs.h Sun Jul 20 19:16:48 2003
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <regex.h>
+
+ extern regex_t *a_ip[];
diff --git a/www/ffproxy/pkg-descr b/www/ffproxy/pkg-descr
new file mode 100644
index 000000000000..9bd4daf69874
--- /dev/null
+++ b/www/ffproxy/pkg-descr
@@ -0,0 +1,9 @@
+ffproxy is a filtering HTTP proxy server. It is able to filter
+by host, URL, and header. Custom header entries can be filtered
+and added. It can even drop its privileges and optionally
+chroot() to some directory. Logging to syslog() is supported,
+as is using another auxiliary proxy server. Contacting IPv6
+servers is supported and allows transparent IPv6 over IPv4
+browsing.
+
+WWW: http://faith.eu.org/programs.html#ffproxy
diff --git a/www/ffproxy/pkg-plist b/www/ffproxy/pkg-plist
new file mode 100644
index 000000000000..d5559eb8c60e
--- /dev/null
+++ b/www/ffproxy/pkg-plist
@@ -0,0 +1,24 @@
+bin/ffproxy
+etc/ffproxy.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/db/access.dyndns
+%%PORTDOCS%%%%DOCSDIR%%/db/access.host
+%%PORTDOCS%%%%DOCSDIR%%/db/access.ip
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.header.add
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.header.drop
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.header.entry
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.header.match
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.host.match
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.rheader.drop
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.rheader.entry
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.rheader.match
+%%PORTDOCS%%%%DOCSDIR%%/db/filter.url.match
+%%PORTDOCS%%%%DOCSDIR%%/html/connect
+%%PORTDOCS%%%%DOCSDIR%%/html/filtered
+%%PORTDOCS%%%%DOCSDIR%%/html/invalid
+%%PORTDOCS%%%%DOCSDIR%%/html/notcached
+%%PORTDOCS%%%%DOCSDIR%%/html/post
+%%PORTDOCS%%%%DOCSDIR%%/html/resolve
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/db
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%