aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-09-13 18:00:57 +0800
committerale <ale@FreeBSD.org>2010-09-13 18:00:57 +0800
commit5b64a49c797459f372e9263aafa0e53216087136 (patch)
tree3057b45e01e87dccf5d4bb233ae77884aba1b77e /www
parent733a66a97ea53d68e940da1bb7f29af459430ad5 (diff)
downloadfreebsd-ports-gnome-5b64a49c797459f372e9263aafa0e53216087136.tar.gz
freebsd-ports-gnome-5b64a49c797459f372e9263aafa0e53216087136.tar.zst
freebsd-ports-gnome-5b64a49c797459f372e9263aafa0e53216087136.zip
Add the ability to create customized packages on tinderbox (i.e. honour OPTIONSFILE).
This can be applied to all other gecko i18n ports. Approved by: beat
Diffstat (limited to 'www')
-rw-r--r--www/seamonkey2-i18n/Makefile11
-rw-r--r--www/seamonkey2-i18n/Makefile.lang2
2 files changed, 4 insertions, 9 deletions
diff --git a/www/seamonkey2-i18n/Makefile b/www/seamonkey2-i18n/Makefile
index dae0638341b2..b4dd01cca14b 100644
--- a/www/seamonkey2-i18n/Makefile
+++ b/www/seamonkey2-i18n/Makefile
@@ -25,13 +25,12 @@ WDIR= langpack-*@seamonkey.mozilla.org
XPI_DISTNAMES= ${SEAMONKEY_I18N_}
-.include "${.CURDIR}/Makefile.option"
-.include <bsd.port.pre.mk>
-
.ifndef WITHOUT_SWITCHER
RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-switcher
.endif
+.include "${.CURDIR}/Makefile.option"
+.include <bsd.port.options.mk>
.include "${.CURDIR}/Makefile.lang"
SEAMONKEY_I18N_?= ${SEAMONKEY_I18N}
@@ -56,10 +55,6 @@ do-extract:
fi \
done
-.if !exists(${OPTIONSFILE}) && !defined(PACKAGE_BUILDING)
-pre-configure: config
-.endif
-
do-install:
@${INSTALL} -d ${XPI_LIBDIR} ${XPI_SLDIRS_ALL}
@${CP} -R ${WRKSRC}/ ${XPI_LIBDIR}/
@@ -84,4 +79,4 @@ List-Langs:
.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/seamonkey2-i18n/Makefile.lang b/www/seamonkey2-i18n/Makefile.lang
index ef6ac23e876d..de1fdfc74ee8 100644
--- a/www/seamonkey2-i18n/Makefile.lang
+++ b/www/seamonkey2-i18n/Makefile.lang
@@ -9,7 +9,7 @@
SEAMONKEY_I18N_ALL_= be ca cs de es-AR es-ES fr gl hu it \
ka lt nb-NO nl pl pt-PT ru sk tr
-.if defined(SEAMONKEY_I18N_ALL) || defined(PACKAGE_BUILDING) || target(package)
+.if defined(SEAMONKEY_I18N_ALL) || (defined(PACKAGE_BUILDING) && !exists(${OPTIONSFILE})) || make(makesum)
SEAMONKEY_I18N= ${SEAMONKEY_I18N_ALL_}
.else
.ifndef WITHOUT_LANG_BE