aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
committermatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
commit5cdd27d7fb9e44673f9bb26594e8f14095624d86 (patch)
tree11614345c7dfeab8d4ba1cd03e07f16921dbc832 /www
parentae608736bd02e8d8d75614fe9b85e32072a72fda (diff)
downloadfreebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.gz
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.zst
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.zip
Reorganise and modernise the py-sqlalchemy ports.
- Introduce new ports for the sqlalchemy 0.9 and 1.0 release branches. - Deprecate the ports for the 0.6 and 0.7 release branches, as these have been declared EoL and are no longer supported by upstream. - Update to the latest available version in each branch. In detail: Port Version Maintainer ---------------------------------------------- py-sqlalchemy06 0.6.9 nivit@FreeBSD.org (Deprecate 2016-08-20) [1] py-sqlalchemy07 0.7.10 nivit@FreeBSD.org (renamed py-sqlalchemy, Deprecate 2016-08-20) [1] py-sqlalchemy08 0.8.7 nivit@FreeBSD.org (renamed py-sqlalchemy-devel) [1] py-sqlalchemy09 0.9.10 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] py-sqlalchemy10 1.0.13 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] - Use options-helpers and option dependent make targets. - Use autoplist for documents as well as python code - Add all the docments to the packages: previously an arbitrary subset was added in a way that excluded CSS, images and other HTML assets. - Use TEST_DEPENDS and add a TEST_TARGET instead of having a 'TEST' option. - Use py-pytest for 0.9.x and later, rather than py-nose. - Add CONFLICTS_INSTALL between all of the py-sqlalchemyXY ports. PR: 191442 Submitted by: robak Reviewed by: robak Reviewed by: pi Approved by: nivit (maintainer timeout, ~300days) [1] Approved by: m.tsatsenko@gmail.com (maintainer) [2] Sponsored by: https://reviews.freebsd.org/D908
Diffstat (limited to 'www')
-rw-r--r--www/geeknote/Makefile2
-rw-r--r--www/py-bottle-cork/Makefile2
-rw-r--r--www/py-flexget/Makefile2
-rw-r--r--www/py-imdbpy/Makefile2
-rw-r--r--www/py-rhodecode/Makefile2
-rw-r--r--www/py-turbogears2/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/www/geeknote/Makefile b/www/geeknote/Makefile
index 7870e2b6728b..a5e35d9ab77e 100644
--- a/www/geeknote/Makefile
+++ b/www/geeknote/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}evernote>=1.17:www/py-evernote \
${PYTHON_PKGNAMEPREFIX}html2text>0:textproc/py-html2text \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>0:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}markdown2>0:textproc/py-markdown2 \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup \
${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift
diff --git a/www/py-bottle-cork/Makefile b/www/py-bottle-cork/Makefile
index 508b957147cd..cfa411c37b7c 100644
--- a/www/py-bottle-cork/Makefile
+++ b/www/py-bottle-cork/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= SQLITE MONGODB SQLALCHEMY EXAMPLES
SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
MONGODB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>0:databases/pymongo
-SQLALCHEMY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy
+SQLALCHEMY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>0:databases/py-sqlalchemy07
.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
diff --git a/www/py-flexget/Makefile b/www/py-flexget/Makefile
index acf9f4743d32..56c36140453f 100644
--- a/www/py-flexget/Makefile
+++ b/www/py-flexget/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paver>=0:devel/py-paver
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=5.1.3:textproc/py-feedparser \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.7.5:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>=0.7.5:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_SITELIBDIR}/BeautifulSoup.py:www/py-beautifulsoup32 \
${PYTHON_SITELIBDIR}/bs4/__init__.py:www/py-beautifulsoup \
diff --git a/www/py-imdbpy/Makefile b/www/py-imdbpy/Makefile
index 18c12a7ba869..b2cf67a00473 100644
--- a/www/py-imdbpy/Makefile
+++ b/www/py-imdbpy/Makefile
@@ -17,7 +17,7 @@ LICENSE_COMB= dual
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}sqlalchemy-migrate>=0.6.1:databases/py-sqlalchemy-migrate \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>=0:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}sqlobject>=0:databases/py-sqlobject
OPTIONS_DEFINE= DOCS
diff --git a/www/py-rhodecode/Makefile b/www/py-rhodecode/Makefile
index 513bf811dae9..4349994444b2 100644
--- a/www/py-rhodecode/Makefile
+++ b/www/py-rhodecode/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylons>=1.0:www/py-pylons \
${PYTHON_PKGNAMEPREFIX}formencode>=1.2.4:www/py-formencode \
${PYTHON_PKGNAMEPREFIX}webhelpers>=1.3:www/py-webhelpers \
${PYTHON_PKGNAMEPREFIX}mako>=0.7.3:textproc/py-mako \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.7.10:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>=0.7.10:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}pygments>=1.5:textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}whoosh>=2.4.0:textproc/py-whoosh \
${PYTHON_PKGNAMEPREFIX}Babel>=0.9.6:devel/py-babel \
diff --git a/www/py-turbogears2/Makefile b/www/py-turbogears2/Makefile
index 2271726a4a70..edc60448183a 100644
--- a/www/py-turbogears2/Makefile
+++ b/www/py-turbogears2/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ToscaWidgets>=0.9.4:devel/py-ToscaWidgets \
${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose \
${PYTHON_PKGNAMEPREFIX}TurboKid>=1.0.4:devel/py-turbokid \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.4:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>=0.4:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2 \
${PYTHON_PKGNAMEPREFIX}Chameleon>=2.0:textproc/py-Chameleon \
${PYTHON_PKGNAMEPREFIX}mako>=0:textproc/py-mako \