aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-06-24 02:22:43 +0800
committerrm <rm@FreeBSD.org>2015-06-24 02:22:43 +0800
commit610f0f8d17b52e0ea6c531702da2d7f0297d63a0 (patch)
tree7c941fdbaeec72ded7da431046121581c3a493d3 /www
parentb874e4bec883bc15fa4484b00af251af577c7f43 (diff)
downloadfreebsd-ports-gnome-610f0f8d17b52e0ea6c531702da2d7f0297d63a0.tar.gz
freebsd-ports-gnome-610f0f8d17b52e0ea6c531702da2d7f0297d63a0.tar.zst
freebsd-ports-gnome-610f0f8d17b52e0ea6c531702da2d7f0297d63a0.zip
www/py-tornado: remove py-backports.ssl_match_hostname dependency
since python 2.7.9 ssl.match_hostname() function is in standard library, so there is no need to depend on security/py-backports.ssl_match_hostname anymore as stated in tornado's setup.py: """ if sys.version_info < (3, 2): install_requires.append('backports.ssl_match_hostname') if sys.version_info < (3, 4): # Certifi is also optional on 2.7.9+, although making our dependencies # conditional on micro version numbers seems like a bad idea # until we have more declarative metadata. install_requires.append('certifi') """ Remove this dependency and bump PORTREVISION. While here sort USE_PYTHON components, add missed space in Makefile header. PR: 201050 Submitted by: rm (myself) Approved by: Guixing Bai <khsing.cn@gmail.com> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/py-tornado/Makefile8
-rw-r--r--www/py-tornado/files/patch-setup.py17
2 files changed, 17 insertions, 8 deletions
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index 3d1caa1ab95c..07e469552aa8 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -1,8 +1,9 @@
-# Created by: Guixing Bai<khsing.cn@gmail.com>
+# Created by: Guixing Bai <khsing.cn@gmail.com>
# $FreeBSD$
PORTNAME= tornado
PORTVERSION= 4.2
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,13 +16,12 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:${PORTSDIR}/security/py-certifi
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.ssl_match_hostname>0:${PORTSDIR}/security/py-backports.ssl_match_hostname \
- ${PYTHON_PKGNAMEPREFIX}futures>0:${PORTSDIR}/devel/py-futures
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:${PORTSDIR}/devel/py-futures
.endif
post-build:
diff --git a/www/py-tornado/files/patch-setup.py b/www/py-tornado/files/patch-setup.py
index e727a5331d5c..a8f0d042de1a 100644
--- a/www/py-tornado/files/patch-setup.py
+++ b/www/py-tornado/files/patch-setup.py
@@ -1,6 +1,15 @@
---- setup.py.orig 2013-04-29 08:46:17.852783104 +0200
-+++ setup.py 2013-04-29 08:46:30.135662912 +0200
-@@ -41,9 +41,6 @@
+--- setup.py.orig 2015-05-27 01:44:57 UTC
++++ setup.py
+@@ -122,7 +122,7 @@ if (platform.python_implementation() ==
+ if setuptools is not None:
+ # If setuptools is not available, you're on your own for dependencies.
+ install_requires = []
+- if sys.version_info < (3, 2):
++ if sys.version_info < (2, 7, 9):
+ install_requires.append('backports.ssl_match_hostname')
+ if sys.version_info < (3, 4):
+ # Certifi is also optional on 2.7.9+, although making our dependencies
+@@ -141,9 +141,6 @@ setup(
# in the sdist tarball)
"tornado.test": [
"README",
@@ -9,4 +18,4 @@
- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.po",
"options_test.cfg",
"static/robots.txt",
- "templates/utf8.html",
+ "static/dir/index.html",