aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-05-18 03:50:15 +0800
committerrobak <robak@FreeBSD.org>2015-05-18 03:50:15 +0800
commit614c3291b132e85ff9befe6e05817469cf4c2f30 (patch)
tree453749a20814d78c133f88945da389a72cb4ea84 /www
parentde73fbbecd260f19b4b7b612b821476a22f3b9fd (diff)
downloadfreebsd-ports-gnome-614c3291b132e85ff9befe6e05817469cf4c2f30.tar.gz
freebsd-ports-gnome-614c3291b132e85ff9befe6e05817469cf4c2f30.tar.zst
freebsd-ports-gnome-614c3291b132e85ff9befe6e05817469cf4c2f30.zip
www/node: update 0.12.2 -> 0.12.3
- Remove obsolete patches PR: 200240 Submitted by: Daniel Lin <linpct@gmail.com> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-lib_dns.js14
-rw-r--r--www/node/files/patch-src_node.cc11
4 files changed, 3 insertions, 28 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 3a97fdbc1be2..14d2f2c2acc3 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 0.12.2
+PORTVERSION= 0.12.3
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
diff --git a/www/node/distinfo b/www/node/distinfo
index cd40d4c925b8..158b0eabc8fe 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.12.2.tar.gz) = ac7e78ade93e633e7ed628532bb8e650caba0c9c33af33581957f3382e2a772d
-SIZE (node-v0.12.2.tar.gz) = 19311976
+SHA256 (node-v0.12.3.tar.gz) = e65d83c6f2c874e28f65c5e192ac0acd2bbb52bfcf9d77e33442d6765a3eb9da
+SIZE (node-v0.12.3.tar.gz) = 19622994
diff --git a/www/node/files/patch-lib_dns.js b/www/node/files/patch-lib_dns.js
deleted file mode 100644
index 9530794fa454..000000000000
--- a/www/node/files/patch-lib_dns.js
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/dns.js.orig 2015-03-31 22:13:01 UTC
-+++ lib/dns.js
-@@ -125,6 +125,11 @@ exports.lookup = function lookup(hostnam
- hints !== (exports.ADDRCONFIG | exports.V4MAPPED)) {
- throw new TypeError('invalid argument: hints must use valid flags');
- }
-+ // FIXME(indutny): V4MAPPED on FreeBSD results in EAI_BADFLAGS, because
-+ // the libc does not support it
-+ if (process.platform === 'freebsd' && family !== 6) {
-+ hints &= ~exports.V4MAPPED;
-+ }
- } else {
- family = options >>> 0;
- }
diff --git a/www/node/files/patch-src_node.cc b/www/node/files/patch-src_node.cc
deleted file mode 100644
index 4f4e1d2e179c..000000000000
--- a/www/node/files/patch-src_node.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/node.cc.orig 2015-04-15 04:37:29 UTC
-+++ src/node.cc
-@@ -2790,7 +2790,7 @@ static void SignalExit(int signo) {
- struct sigaction sa;
- memset(&sa, 0, sizeof(sa));
- sa.sa_handler = SIG_DFL;
-- CHECK_EQ(sigaction(signo, &sa, nullptr), 0);
-+ CHECK_EQ(sigaction(signo, &sa, NULL), 0);
- #endif
- raise(signo);
- }