aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-24 11:55:41 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-24 11:55:41 +0800
commit620716986f14dfdba2430a37c3e88a139622cd0c (patch)
tree8b975bc7579f291b4c132f0ccb230309994a41e1 /www
parent317795552b679fe87b9713ceed8f82d3fc494446 (diff)
downloadfreebsd-ports-gnome-620716986f14dfdba2430a37c3e88a139622cd0c.tar.gz
freebsd-ports-gnome-620716986f14dfdba2430a37c3e88a139622cd0c.tar.zst
freebsd-ports-gnome-620716986f14dfdba2430a37c3e88a139622cd0c.zip
A Sinatra extension that provides i18n support to translate your
web application. It is just a wrapper for R18n core library. It has nice Ruby-style syntax, filters, flexible locales, custom loaders, translation support for any classes, time and number localization, several user language support, agnostic core package with out-of-box support for Rails, Sinatra and desktop applications. WWW: https://github.com/ai/r18n/tree/master/sinatra-r18n
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-sinatra-r18n/Makefile21
-rw-r--r--www/rubygem-sinatra-r18n/distinfo2
-rw-r--r--www/rubygem-sinatra-r18n/pkg-descr8
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aa2a8ff175e5..ab372ad4e4d8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1820,6 +1820,7 @@
SUBDIR += rubygem-selenium-webdriver
SUBDIR += rubygem-simple-rss
SUBDIR += rubygem-sinatra
+ SUBDIR += rubygem-sinatra-r18n
SUBDIR += rubygem-sinatra-respond_to
SUBDIR += rubygem-staticmatic
SUBDIR += rubygem-taggable
diff --git a/www/rubygem-sinatra-r18n/Makefile b/www/rubygem-sinatra-r18n/Makefile
new file mode 100644
index 000000000000..5ca40ad9b2a6
--- /dev/null
+++ b/www/rubygem-sinatra-r18n/Makefile
@@ -0,0 +1,21 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sinatra-r18n
+PORTVERSION= 1.1.6
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Sinatra extension that provides i18n support to your web application
+
+RUN_DEPENDS= rubygem-sinatra>=1.3:${PORTSDIR}/www/rubygem-sinatra \
+ rubygem-r18n-core=${PORTVERSION}:${PORTSDIR}/devel/rubygem-r18n-core
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-sinatra-r18n/distinfo b/www/rubygem-sinatra-r18n/distinfo
new file mode 100644
index 000000000000..9e6609c57436
--- /dev/null
+++ b/www/rubygem-sinatra-r18n/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/sinatra-r18n-1.1.6.gem) = 1009176ea017199bc9effe91b54b28c2a46846eacc9b47ecd8b6c5b3a4b81267
+SIZE (rubygem/sinatra-r18n-1.1.6.gem) = 9728
diff --git a/www/rubygem-sinatra-r18n/pkg-descr b/www/rubygem-sinatra-r18n/pkg-descr
new file mode 100644
index 000000000000..ecdd721e8267
--- /dev/null
+++ b/www/rubygem-sinatra-r18n/pkg-descr
@@ -0,0 +1,8 @@
+A Sinatra extension that provides i18n support to translate your
+web application. It is just a wrapper for R18n core library. It has
+nice Ruby-style syntax, filters, flexible locales, custom loaders,
+translation support for any classes, time and number localization,
+several user language support, agnostic core package with out-of-box
+support for Rails, Sinatra and desktop applications.
+
+WWW: https://github.com/ai/r18n/tree/master/sinatra-r18n