aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-03-30 03:03:17 +0800
committertcberner <tcberner@FreeBSD.org>2018-03-30 03:03:17 +0800
commit63c259ca10bd425e19413bfa43d923baee86a1d4 (patch)
tree5830350c230c42b929c6bc665e376f2852edce93 /www
parent087918eb2302a4446c0110d6db410278b3ae3e6c (diff)
downloadfreebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.tar.gz
freebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.tar.zst
freebsd-ports-gnome-63c259ca10bd425e19413bfa43d923baee86a1d4.zip
Fix permissions in installed Qt5 header files
For the qt5-* ports bsd.qt.mk sets EXTRACT_AFTER_ARGS, and thereby does not get the normal default value of --no-same-owner --no-same-permissions passed when extracting. This lead to for example header files being installed (i.e. copied), with permissions group write permissions. Manually append that to the bsd.qt.mk shenanigans (also do the same in www/qt5-webchannel, which opts out of the bsd.qt.mk value) PR: 227027 Reported by: grarpamp@gmail.com
Diffstat (limited to 'www')
-rw-r--r--www/qt5-webchannel/Makefile3
-rw-r--r--www/qt5-webengine/Makefile1
-rw-r--r--www/qt5-websockets-qml/Makefile1
-rw-r--r--www/qt5-websockets/Makefile1
4 files changed, 5 insertions, 1 deletions
diff --git a/www/qt5-webchannel/Makefile b/www/qt5-webchannel/Makefile
index 36c585463b29..3de1902bc592 100644
--- a/www/qt5-webchannel/Makefile
+++ b/www/qt5-webchannel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webchannel
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -15,6 +16,6 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
# The default EXTRACT_AFTER_ARGS value excludes examples/ from the extracted
# tarball, which we need during the build.
-EXTRACT_AFTER_ARGS= # empty
+EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions
.include <bsd.port.mk>
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 9116d942ffa3..d1bd66c96a83 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -16,6 +16,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
diff --git a/www/qt5-websockets-qml/Makefile b/www/qt5-websockets-qml/Makefile
index 3a75f8e41811..6460b08afd36 100644
--- a/www/qt5-websockets-qml/Makefile
+++ b/www/qt5-websockets-qml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= websockets-qml
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
diff --git a/www/qt5-websockets/Makefile b/www/qt5-websockets/Makefile
index fb1b34b696b8..7642d164e989 100644
--- a/www/qt5-websockets/Makefile
+++ b/www/qt5-websockets/Makefile
@@ -2,6 +2,7 @@
PORTNAME= websockets
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-