aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2006-01-16 18:13:26 +0800
committerclement <clement@FreeBSD.org>2006-01-16 18:13:26 +0800
commit65b1b1980f1138d7372dcbb48370c748d37f930f (patch)
tree6c08d027b0ff66afbba43d1ff20c9d4cd2472de1 /www
parent7d9dda2d8500e29b22999044841b9e44889d00d9 (diff)
downloadfreebsd-ports-gnome-65b1b1980f1138d7372dcbb48370c748d37f930f.tar.gz
freebsd-ports-gnome-65b1b1980f1138d7372dcbb48370c748d37f930f.tar.zst
freebsd-ports-gnome-65b1b1980f1138d7372dcbb48370c748d37f930f.zip
- Remove duplicated mor_dir entries
- Always build (mod_)apache_ssl statically. - Fix MAN8 logic [1] Reported by: pointyhat via kris [1]
Diffstat (limited to 'www')
-rw-r--r--www/apache13-ssl/Makefile9
-rw-r--r--www/apache13-ssl/Makefile.modules10
-rw-r--r--www/apache13-ssl/pkg-plist2
3 files changed, 9 insertions, 12 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index f066eca9cf18..868712ed3e45 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -9,6 +9,7 @@
PORTNAME= apache+ssl
PORTVERSION= ${APACHE_VERSION}.${APACHE_SSL_VERSION}
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITES_APACHE_SSL:S/$/:ssl/}
@@ -41,8 +42,6 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} WWWOWN=${WWWOWN}
MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
USE_APACHE= common13
-.include "${.CURDIR}/Makefile.modules"
-
MASTER_SITES_APACHE_SSL= \
ftp://ftp.ox.ac.uk/pub/crypto/SSL/Apache-SSL/ \
ftp://ftp.it.net.au/mirrors/crypto/SSL/Apache-SSL/ \
@@ -84,16 +83,16 @@ CONFIGURE_ENV+= OPTIM='${OPTIM}'
CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -L${LOCALBASE}/lib"
.if defined(WITH_SUEXEC)
-SUEXEC_MAN= suexec.8
+MAN8= suexec.8
PLIST_SUB+= SUB_SUEXEC=""
.else
PLIST_SUB+= SUB_SUEXEC="@comment "
.endif
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
-MAN8= ab.8 httpsdctl.8 apxs.8 httpsd.8 logresolve.8 rotatelogs.8 \
- ${SUEXEC_MAN}
+MAN8+= ab.8 httpsdctl.8 apxs.8 httpsd.8 logresolve.8 rotatelogs.8
+.include "${.CURDIR}/Makefile.modules"
.include <bsd.port.pre.mk>
post-extract:
diff --git a/www/apache13-ssl/Makefile.modules b/www/apache13-ssl/Makefile.modules
index ab882c6264e9..8ff5b36d529f 100644
--- a/www/apache13-ssl/Makefile.modules
+++ b/www/apache13-ssl/Makefile.modules
@@ -1,10 +1,6 @@
# Makefile.modules
# Author: Clement Laforet <clement@FreeBSD.org>
#
-# This file is used to build modules list, DBM dependencies and MPM selection.
-# I hope it can easily handle external modules (such as mod_perl) or MPMs, like
-# muxmpm.
-#
# Note to myself: (to generate PLIST_SUB entries for modules)
# gsed 's/^\(.*\)mod\(.*\)\.so/%%\MOD\U\2%%\L\1mod\2\.so/' pkg-plist > tmp
# mv tmp pkg-plist
@@ -16,7 +12,7 @@ AUTH_MODULES= access auth auth_anon auth_dbm auth_db auth_digest
LOG_MODULES= log_forensic log_referer log_agent
MMAP_MODULES= mmap_static
MISC_MODULES= actions alias asis autoindex cern_meta cgi digest \
- dir env expires dir headers imap include \
+ dir env expires headers imap include \
info log_config mime mime_magic negotiation rewrite \
speling status unique_id userdir usertrack vhost_alias
PROXY_MODULES= proxy
@@ -26,3 +22,7 @@ DEFAULT_MODULES_CATEGORIES= \
AUTH LOG MMAP MISC SSL
ALL_MODULES_CATEGORIES= AUTH LOG MMAP MISC PROXY SSL
+
+.if !defined(WITH_ALL_STATIC_MODULES)
+WITH_STATIC_MODULES+= apache_ssl
+.endif
diff --git a/www/apache13-ssl/pkg-plist b/www/apache13-ssl/pkg-plist
index bebdab4f3cf4..5e916c354830 100644
--- a/www/apache13-ssl/pkg-plist
+++ b/www/apache13-ssl/pkg-plist
@@ -70,7 +70,6 @@ libexec/apache/httpd.exp
%%MOD_ACCESS%%libexec/apache/mod_access.so
%%MOD_ACTIONS%%libexec/apache/mod_actions.so
%%MOD_ALIAS%%libexec/apache/mod_alias.so
-@comment %%MOD_APACHE_SSL%%libexec/apache/mod_apache_ssl.so
%%MOD_ASIS%%libexec/apache/mod_asis.so
%%MOD_AUTH%%libexec/apache/mod_auth.so
%%MOD_AUTH_ANON%%libexec/apache/mod_auth_anon.so
@@ -81,7 +80,6 @@ libexec/apache/httpd.exp
%%MOD_CERN_META%%libexec/apache/mod_cern_meta.so
%%MOD_CGI%%libexec/apache/mod_cgi.so
%%MOD_DIGEST%%libexec/apache/mod_digest.so
-@comment %%MOD_DIR%%libexec/apache/mod_dir.so
%%MOD_DIR%%libexec/apache/mod_dir.so
%%MOD_ENV%%libexec/apache/mod_env.so
%%MOD_EXPIRES%%libexec/apache/mod_expires.so