aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-28 02:47:20 +0800
committerrm <rm@FreeBSD.org>2012-10-28 02:47:20 +0800
commit66d22558c3b0b357b9a072e50de4e717ef7e874a (patch)
treed4a9b773b41bb3cce25ee9318a612bfbdf24e2a9 /www
parent393a825a850145dac54d308837041c760c00a557 (diff)
downloadfreebsd-ports-gnome-66d22558c3b0b357b9a072e50de4e717ef7e874a.tar.gz
freebsd-ports-gnome-66d22558c3b0b357b9a072e50de4e717ef7e874a.tar.zst
freebsd-ports-gnome-66d22558c3b0b357b9a072e50de4e717ef7e874a.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES Approved by: glarkin (maintainer, implicit) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-macropost/Makefile18
-rw-r--r--www/trac-macropost/pkg-plist1
2 files changed, 6 insertions, 13 deletions
diff --git a/www/trac-macropost/Makefile b/www/trac-macropost/Makefile
index 21c60540964c..fc615592c789 100644
--- a/www/trac-macropost/Makefile
+++ b/www/trac-macropost/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-macropostplugin
-# Date created: 17 May 2007
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= macropost
PORTVERSION= 0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= http://www.gerritbeine.de/download/trac/
PKGNAMEPREFIX= trac-
@@ -17,13 +13,11 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= Allows Macros to use POST in forms
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
WRKSRC= ${WRKDIR}/${PORTNAME}plugin
-NO_BUILD= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= TracMacroPost
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/www/trac-macropost/pkg-plist b/www/trac-macropost/pkg-plist
deleted file mode 100644
index 10a36ba735a1..000000000000
--- a/www/trac-macropost/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/TracMacroPost-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg