aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-06-05 12:43:14 +0800
committerkoobs <koobs@FreeBSD.org>2015-06-05 12:43:14 +0800
commit67f1be42f3d26a6fc03871922e46ed33586476fc (patch)
treed7bc03d977779c3c045dd88ad69cea81cb5dd7dd /www
parent7b3fb991959264c470adedf9ef35e6f410a9e059 (diff)
downloadfreebsd-ports-gnome-67f1be42f3d26a6fc03871922e46ed33586476fc.tar.gz
freebsd-ports-gnome-67f1be42f3d26a6fc03871922e46ed33586476fc.tar.zst
freebsd-ports-gnome-67f1be42f3d26a6fc03871922e46ed33586476fc.zip
www/py-requests: Update to 2.7.0
- Update to 2.7.0 - Update regression-test to canonical test invocation [1] - Patch setup.py to add tests dependencies and support test command [1] Changes: https://github.com/kennethreitz/requests/blob/v2.7.0/HISTORY.rst [1] https://github.com/kennethreitz/requests/pull/2630
Diffstat (limited to 'www')
-rw-r--r--www/py-requests/Makefile4
-rw-r--r--www/py-requests/distinfo4
-rw-r--r--www/py-requests/files/patch-setup.py19
3 files changed, 23 insertions, 4 deletions
diff --git a/www/py-requests/Makefile b/www/py-requests/Makefile
index 08009a15554c..49cc2c4e62a4 100644
--- a/www/py-requests/Makefile
+++ b/www/py-requests/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= requests
-PORTVERSION= 2.4.3
+PORTVERSION= 2.7.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,6 +21,6 @@ USE_PYTHON= autoplist distutils
CONFLICTS_INSTALL= py*-requests1-*
regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} test_requests.py
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/www/py-requests/distinfo b/www/py-requests/distinfo
index fd5d35214c20..af2b513590b4 100644
--- a/www/py-requests/distinfo
+++ b/www/py-requests/distinfo
@@ -1,2 +1,2 @@
-SHA256 (requests-2.4.3.tar.gz) = 53c68313c5c6149b1a899234c000296e60a8900682accf73d6f0c6d608afc6b1
-SIZE (requests-2.4.3.tar.gz) = 438132
+SHA256 (requests-2.7.0.tar.gz) = 398a3db6d61899d25fd4a06c6ca12051b0ce171d705decd7ed5511517b4bb93d
+SIZE (requests-2.7.0.tar.gz) = 451723
diff --git a/www/py-requests/files/patch-setup.py b/www/py-requests/files/patch-setup.py
new file mode 100644
index 000000000000..0e8158983c4a
--- /dev/null
+++ b/www/py-requests/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2015-06-05 04:36:25 UTC
++++ setup.py
+@@ -27,6 +27,7 @@ packages = [
+ ]
+
+ requires = []
++tests_require = ['pytest']
+
+ version = ''
+ with open('requests/__init__.py', 'r') as fd:
+@@ -54,6 +55,8 @@ setup(
+ package_dir={'requests': 'requests'},
+ include_package_data=True,
+ install_requires=requires,
++ tests_require=tests_require,
++ test_suite='test_requests',
+ license='Apache 2.0',
+ zip_safe=False,
+ classifiers=(