aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-30 06:42:08 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-30 06:42:08 +0800
commit696ce8f5aedd9ab1a4bfa5f3d4e3a415f2714ef1 (patch)
tree3487994c797be798ffc271b2f9dfb264906bf72b /www
parentf619b31fc7c8ed07cb7653d729c403ae110babd2 (diff)
downloadfreebsd-ports-gnome-696ce8f5aedd9ab1a4bfa5f3d4e3a415f2714ef1.tar.gz
freebsd-ports-gnome-696ce8f5aedd9ab1a4bfa5f3d4e3a415f2714ef1.tar.zst
freebsd-ports-gnome-696ce8f5aedd9ab1a4bfa5f3d4e3a415f2714ef1.zip
- Remove all options: npm 3.x will be available only for current version of Node.js (www/node)
Discussed with: Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer of www/node*)
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 84baeb72038a..a7e6b64d085a 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -11,18 +11,11 @@ COMMENT= Node package manager
LICENSE= MIT
-RUN_DEPENDS= gmake:devel/gmake
+RUN_DEPENDS= gmake:devel/gmake \
+ node>=0.8.0:www/node
CONFLICTS_INSTALL= npm2-[0-9]*
-OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE010 NODE012 NODE4
-OPTIONS_DEFAULT=NODE
-NODE_DESC= Use www/node as backend
-NODE010_DESC= Use www/node010 as backend
-NODE012_DESC= Use www/node012 as backend
-NODE4_DESC= Use www/node4 as backend
-
MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
MANPREFIX= ${PREFIX}/lib/node_modules/npm
NO_ARCH= yes
@@ -40,11 +33,6 @@ SHEBANG_FILES= lib/utils/completion.sh \
scripts/release.sh \
scripts/relocate.sh
-NODE_RUN_DEPENDS= node>=0.8.0:www/node
-NODE010_RUN_DEPENDS= node010>=0.8.0:www/node010
-NODE012_RUN_DEPENDS= node012>=0.8.0:www/node012
-NODE4_RUN_DEPENDS= node4>=0.8.0:www/node4
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"