aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-06-25 01:26:42 +0800
committerhrs <hrs@FreeBSD.org>2007-06-25 01:26:42 +0800
commit6baea23fb3e12ff7533da280dc0082ee07eace7b (patch)
tree9633a26fb389605177d2261961ea19727b681928 /www
parent1ec0d6489d8cde11a10a189c67ee2be9717ccaf0 (diff)
downloadfreebsd-ports-gnome-6baea23fb3e12ff7533da280dc0082ee07eace7b.tar.gz
freebsd-ports-gnome-6baea23fb3e12ff7533da280dc0082ee07eace7b.tar.zst
freebsd-ports-gnome-6baea23fb3e12ff7533da280dc0082ee07eace7b.zip
Add www/wikicalc, an open source wiki-spreadsheet.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/wikicalc/Makefile42
-rw-r--r--www/wikicalc/distinfo3
-rw-r--r--www/wikicalc/files/setup.sh.in25
-rw-r--r--www/wikicalc/pkg-descr8
-rw-r--r--www/wikicalc/pkg-plist41
6 files changed, 120 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c13e8d64da34..a7482c84b46f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1247,6 +1247,7 @@
SUBDIR += webstone
SUBDIR += webstone-ssl
SUBDIR += wget4web
+ SUBDIR += wikicalc
SUBDIR += wikindx
SUBDIR += wiliki
SUBDIR += winhelpcgi
diff --git a/www/wikicalc/Makefile b/www/wikicalc/Makefile
new file mode 100644
index 000000000000..66e3ba8bcff9
--- /dev/null
+++ b/www/wikicalc/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: wikicalc
+# Date created: June 24, 2007
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= wikicalc
+PORTVERSION= 1.0
+CATEGORIES= www math
+MASTER_SITES= http://www.peapodcast.com/sgi/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,-,}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= An Open Source Wiki-Spreadsheet
+
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= setup.sh
+SUB_LIST= DATADIR=${DATADIR}
+
+post-extract:
+ @${RM} -f ${WRKSRC}/gpl.txt
+
+post-patch:
+ ${REINPLACE_CMD} 's,/usr/bin/perl,${PERL5} -I${DATADIR},' ${WRKSRC}/*.pl
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && \
+ for i in `${FIND} . -type f -a ! -name \*.pl -a ! -name \*.bak`; do \
+ ${INSTALL_DATA} $${i} ${DATADIR}/$${i}; \
+ done; \
+ for i in `${FIND} . -type f -a -name \*.pl`; do \
+ ${INSTALL_SCRIPT} $${i} ${DATADIR}/$${i}; \
+ done
+ ${INSTALL_SCRIPT} ${WRKDIR}/setup.sh ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/wikicalc/distinfo b/www/wikicalc/distinfo
new file mode 100644
index 000000000000..817e6887decf
--- /dev/null
+++ b/www/wikicalc/distinfo
@@ -0,0 +1,3 @@
+MD5 (wikicalc-1-0.tar.gz) = ecd5273fcba92caa7d3575488b83bbbc
+SHA256 (wikicalc-1-0.tar.gz) = 330296dd24e827c8344a2e109bc406592b1423f470ec040677c82c70df3c9014
+SIZE (wikicalc-1-0.tar.gz) = 217909
diff --git a/www/wikicalc/files/setup.sh.in b/www/wikicalc/files/setup.sh.in
new file mode 100644
index 000000000000..a0749b8abf12
--- /dev/null
+++ b/www/wikicalc/files/setup.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+# $FreeBSD$
+
+ask_noyes()
+{
+ local key
+
+ echo -n "$1 [y/N]: "
+ read key
+ case "$key" in
+ [Yy]*)
+ return 0;;
+ *)
+ return 1;;
+ esac
+}
+
+echo "This script will setup current directory for wikicalc."
+if ask_noyes "Are you ready?"; then
+ ln -s -f %%DATADIR%%/* .
+ echo "done."
+else
+ echo "Stopped."
+ exit 1
+fi
diff --git a/www/wikicalc/pkg-descr b/www/wikicalc/pkg-descr
new file mode 100644
index 000000000000..272c69839992
--- /dev/null
+++ b/www/wikicalc/pkg-descr
@@ -0,0 +1,8 @@
+The wikiCalc program lets you make web pages with more than just
+paragraphs of prose. It combines the ease of authoring and multi-person
+editing of a wiki with the familiar visual formatting and calculating
+metaphor of a spreadsheet. Written in Perl and released under the GPL 2.0
+license, it can easily be setup to run on almost any server as a web
+application or on a personal computer to publish by FTP.
+
+WWW: http://www.softwaregarden.com/products/wikicalc/index.html
diff --git a/www/wikicalc/pkg-plist b/www/wikicalc/pkg-plist
new file mode 100644
index 000000000000..e43f5cb2c5e6
--- /dev/null
+++ b/www/wikicalc/pkg-plist
@@ -0,0 +1,41 @@
+@comment $FreeBSD$
+%%DATADIR%%/1x1.gif
+%%DATADIR%%/WKC.pm
+%%DATADIR%%/WKCBackupCommands.pm
+%%DATADIR%%/WKCDataFiles.pm
+%%DATADIR%%/WKCFormatCommands.pm
+%%DATADIR%%/WKCLicense.pm
+%%DATADIR%%/WKCPageCommands.pm
+%%DATADIR%%/WKCSheet.pm
+%%DATADIR%%/WKCSheetFunctions.pm
+%%DATADIR%%/WKCStrings.pm
+%%DATADIR%%/WKCToolsCommands.pm
+%%DATADIR%%/WKCcallableUtilities.pl
+%%DATADIR%%/WKCdefinitions.txt
+%%DATADIR%%/WKCeditjs.txt
+%%DATADIR%%/WKCembeddablejs.txt
+%%DATADIR%%/WKCformatjs.txt
+%%DATADIR%%/WKCjs.txt
+%%DATADIR%%/WKCloadsheetjs.txt
+%%DATADIR%%/WKCnewpagejs.txt
+%%DATADIR%%/WKCpreviewjs.txt
+%%DATADIR%%/WKCtextdata.txt
+%%DATADIR%%/autowidth.pagetemplate.txt
+%%DATADIR%%/autowidth1.htmltemplate.txt
+%%DATADIR%%/autowidth2.htmltemplate.txt
+%%DATADIR%%/col8header.pagetemplate.txt
+%%DATADIR%%/colsizehandle.gif
+%%DATADIR%%/colsizescale.gif
+%%DATADIR%%/demosetup.script.txt
+%%DATADIR%%/fixed1.htmltemplate.txt
+%%DATADIR%%/fixed2.htmltemplate.txt
+%%DATADIR%%/hatchbg.gif
+%%DATADIR%%/wikicalc.ico
+%%DATADIR%%/wikicalc.pl
+%%DATADIR%%/wikicalc16.ico
+%%DATADIR%%/wikicalc16bw.ico
+%%DATADIR%%/wikicalccgi.pl
+%%DATADIR%%/wikicalcmodperl.pl
+%%DATADIR%%/wikicalcwin.pl
+%%DATADIR%%/setup.sh
+@dirrm %%DATADIR%%