aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-07-08 14:28:06 +0800
committerrm <rm@FreeBSD.org>2014-07-08 14:28:06 +0800
commit6becbe70435923fc1e4b5089bd8113daee65ed5d (patch)
tree104635405fcd8a6a1f6bd6942c5cb4731ad13a36 /www
parentab9a7bab735d9484584afb4bdafaa52162ef9cce (diff)
downloadfreebsd-ports-gnome-6becbe70435923fc1e4b5089bd8113daee65ed5d.tar.gz
freebsd-ports-gnome-6becbe70435923fc1e4b5089bd8113daee65ed5d.tar.zst
freebsd-ports-gnome-6becbe70435923fc1e4b5089bd8113daee65ed5d.zip
www/py-html5lib: update python version
- update python version: 3.x is now supported - add tests PR: 191385 Submitted by: melvyn@magemana.nl Reviewed by: koobs
Diffstat (limited to 'www')
-rw-r--r--www/py-html5lib/Makefile28
-rw-r--r--www/py-html5lib/distinfo2
2 files changed, 27 insertions, 3 deletions
diff --git a/www/py-html5lib/Makefile b/www/py-html5lib/Makefile
index 38e1d5ac6961..57b88f2b93ea 100644
--- a/www/py-html5lib/Makefile
+++ b/www/py-html5lib/Makefile
@@ -4,8 +4,9 @@
PORTNAME= html5lib
PORTVERSION= 0.999
CATEGORIES= www python
-MASTER_SITES= GOOGLE_CODE \
- CHEESESHOP
+MASTER_SITES= GOOGLE_CODE:master \
+ CHEESESHOP:master \
+ http://magemana.nl/ports/dist/:test
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rm@FreeBSD.org
@@ -13,8 +14,29 @@ COMMENT= Python based HTML parser based on the HTML5 spec
LICENSE= MIT
-USE_PYTHON= 2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+OPTIONS_DEFINE= TEST
+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+.include <bsd.port.options.mk>
+
+.if !empty(PORT_OPTIONS:MTEST)
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:master \
+ ${PORTNAME}-${PORTVERSION}-testdata${EXTRACT_SUFX}:test
+BUILD_DEPENDS+= ${TEST_DEPENDS}
+.endif
+
+regression-test: build
+ @${ECHO_MSG} "===> Testing ${PORTNAME} (patience...)"
+ @cd ${WRKSRC} && nosetests -q
+
+.if !empty(PORT_OPTIONS:MTEST)
+pre-install: regression-test
+.endif
+
.include <bsd.port.mk>
diff --git a/www/py-html5lib/distinfo b/www/py-html5lib/distinfo
index 1de8bee1f6f5..8a5b0bd70f64 100644
--- a/www/py-html5lib/distinfo
+++ b/www/py-html5lib/distinfo
@@ -1,2 +1,4 @@
SHA256 (html5lib-0.999.tar.gz) = c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e
SIZE (html5lib-0.999.tar.gz) = 885440
+SHA256 (html5lib-0.999-testdata.tar.gz) = 27c6b2d9668aecf893a34a25ce19af324d5d8ba3acd734ea2915321a3d03a9cd
+SIZE (html5lib-0.999-testdata.tar.gz) = 788956