aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-21 12:03:39 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-21 12:03:39 +0800
commit6d293048a275870e3fa9228ab07cf55ead9fbac8 (patch)
tree25df2eb195daff39e59e4feb3dbd4522184246ab /www
parent077ddf78bba80655d848ef8fb709aeaefbdb865a (diff)
downloadfreebsd-ports-gnome-6d293048a275870e3fa9228ab07cf55ead9fbac8.tar.gz
freebsd-ports-gnome-6d293048a275870e3fa9228ab07cf55ead9fbac8.tar.zst
freebsd-ports-gnome-6d293048a275870e3fa9228ab07cf55ead9fbac8.zip
Dancer::Plugin::DataFu is an HTML form and table rendering engine with data
validation support. WWW: http://search.cpan.org/~awncorp/Dancer-Plugin-DataFu/ PR: ports/153316 Submitted by: Grzegorz Blach <magik at roorback.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Plugin-DataFu/Makefile34
-rw-r--r--www/p5-Dancer-Plugin-DataFu/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-DataFu/pkg-descr4
-rw-r--r--www/p5-Dancer-Plugin-DataFu/pkg-plist31
5 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 53baf3b4efd7..7f25cd3588da 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -909,6 +909,7 @@
SUBDIR += p5-Corona
SUBDIR += p5-DBIx-Class-HTMLWidget
SUBDIR += p5-Dancer
+ SUBDIR += p5-Dancer-Plugin-DataFu
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-FAQ-OMatic
diff --git a/www/p5-Dancer-Plugin-DataFu/Makefile b/www/p5-Dancer-Plugin-DataFu/Makefile
new file mode 100644
index 000000000000..c991d1826dd8
--- /dev/null
+++ b/www/p5-Dancer-Plugin-DataFu/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Dancer-Plugin-DataFu
+# Date created: 20 Dec 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-DataFu
+PORTVERSION= 1.103070
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AW/AWNCORP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Dancer HTML Form and Grid/Table engine with Input Validation
+
+RUN_DEPENDS= p5-Dancer>=1.2:${PORTSDIR}/www/p5-Dancer \
+ p5-Array-Unique>0:${PORTSDIR}/devel/p5-Array-Unique \
+ p5-Data-Dumper-Concise>0:${PORTSDIR}/devel/p5-Data-Dumper-Concise \
+ p5-File-ShareDir>0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Hash-Merge>0:${PORTSDIR}/textproc/p5-Hash-Merge \
+ p5-Oogly>=0.31:${PORTSDIR}/devel/p5-Oogly \
+ p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dancer-datafu.1
+MAN3= Dancer::Plugin::DataFu.3 \
+ Dancer::Plugin::DataFu::Form.3 \
+ Dancer::Plugin::DataFu::Grid.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-DataFu/distinfo b/www/p5-Dancer-Plugin-DataFu/distinfo
new file mode 100644
index 000000000000..137cb3f70547
--- /dev/null
+++ b/www/p5-Dancer-Plugin-DataFu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-DataFu-1.103070.tar.gz) = 6e5d34a419127c6239308cd529a1e17918cd8c1db5386674a9ab9c9ecfdc3565
+SIZE (Dancer-Plugin-DataFu-1.103070.tar.gz) = 17537
diff --git a/www/p5-Dancer-Plugin-DataFu/pkg-descr b/www/p5-Dancer-Plugin-DataFu/pkg-descr
new file mode 100644
index 000000000000..c57b7e352410
--- /dev/null
+++ b/www/p5-Dancer-Plugin-DataFu/pkg-descr
@@ -0,0 +1,4 @@
+Dancer::Plugin::DataFu is an HTML form and table rendering engine with data
+validation support.
+
+WWW: http://search.cpan.org/~awncorp/Dancer-Plugin-DataFu/
diff --git a/www/p5-Dancer-Plugin-DataFu/pkg-plist b/www/p5-Dancer-Plugin-DataFu/pkg-plist
new file mode 100644
index 000000000000..25f9c73c88d8
--- /dev/null
+++ b/www/p5-Dancer-Plugin-DataFu/pkg-plist
@@ -0,0 +1,31 @@
+bin/dancer-datafu
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/DataFu/.packlist
+%%SITE_PERL%%/Dancer/Plugin/DataFu.pm
+%%SITE_PERL%%/Dancer/Plugin/DataFu/Form.pm
+%%SITE_PERL%%/Dancer/Plugin/DataFu/Grid.pm
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/select_multiple.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_checkbox.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_text.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/select.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/form.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/trow.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/table.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_file.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/tdata.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/theader.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/textarea.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_radio.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/tnavigation.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_password.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/input_hidden.tt
+%%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements/thead.tt
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin/DataFu
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer
+@dirrmtry %%SITE_PERL%%/auto/Dancer/Plugin/DataFu/elements
+@dirrmtry %%SITE_PERL%%/auto/Dancer/Plugin/DataFu
+@dirrmtry %%SITE_PERL%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/auto/Dancer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/DataFu
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer