aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-07 04:03:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-07 04:03:16 +0800
commit6e547c206b1f4bc6ca1d313effa49d2964591457 (patch)
treed6a57de0e89522b7f7a443b7a9268e0d5a4eb9c7 /www
parent90ac8ce6df4c8b453e504ec44f05fdacc033997c (diff)
downloadfreebsd-ports-gnome-6e547c206b1f4bc6ca1d313effa49d2964591457.tar.gz
freebsd-ports-gnome-6e547c206b1f4bc6ca1d313effa49d2964591457.tar.zst
freebsd-ports-gnome-6e547c206b1f4bc6ca1d313effa49d2964591457.zip
- Update to 2013.11.06
- Update MASTER_SITES - Remove leading indefinite article from COMMENT - Convert to new options helper - Support STAGEDIR - Update pkg-message after multimedia/ffmpeg-devel removal - Update WWW PR: ports/183103 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 18 days)
Diffstat (limited to 'www')
-rw-r--r--www/youtube_dl/Makefile33
-rw-r--r--www/youtube_dl/distinfo4
-rw-r--r--www/youtube_dl/files/patch-Makefile26
-rw-r--r--www/youtube_dl/pkg-descr2
-rw-r--r--www/youtube_dl/pkg-message4
5 files changed, 26 insertions, 43 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 1b6c91475496..6633befd3856 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -1,15 +1,13 @@
# $FreeBSD$
PORTNAME= youtube_dl
-PORTVERSION= 2013.09.24.2
-PORTREVISION= 1
+PORTVERSION= 2013.11.06
CATEGORIES= www
-MASTER_SITES= http://youtube-dl.org/downloads/${PORTVERSION}/ \
- http://ftp.de.netbsd.org/pub/unix/Linux/MIRROR.gentoo/distfiles/
+MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
MAINTAINER= araujo@FreeBSD.org
-COMMENT= A program for downloading videos from YouTube.com
+COMMENT= Program for downloading videos from YouTube.com
LICENSE= UNLICENSE
LICENSE_NAME= The Unlicense
@@ -32,36 +30,23 @@ PLIST_FILES= bin/youtube-dl \
WRKSRC= ${WRKDIR}/youtube-dl
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRTMPDUMP}
-RUN_DEPENDS+= rtmpdump:${PORTSDIR}/multimedia/rtmpdump
-.endif
-
-.if ${PORT_OPTIONS:MBASH}
-PLIST_FILES+= etc/bash_completion.d/youtube-dl.sh
-.endif
+BASH_PLIST_FILES= etc/bash_completion.d/youtube-dl.sh
+FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffprobe:${PORTSDIR}/multimedia/ffmpeg
+RTMPDUMP_RUN_DEPENDS= ${LOCALBASE}/bin/rtmpdump:${PORTSDIR}/multimedia/rtmpdump
-.if ${PORT_OPTIONS:MFFMPEG}
-RUN_DEPENDS+= ffprobe:${PORTSDIR}/multimedia/ffmpeg
-.endif
+.include <bsd.port.options.mk>
post-extract:
@# remove tarball provided version, build our own
@${RM} -f ${WRKSRC}/youtube-dl
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${STAGEDIR}${PREFIX}/bin/youtube-dl
- @${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${STAGEDIR}${PREFIX}/bin/youtube-dl
+ ${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${STAGEDIR}${PREFIX}/man/man1/
.if ${PORT_OPTIONS:MBASH}
${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_DATA} ${WRKSRC}/youtube-dl.bash-completion \
${STAGEDIR}${PREFIX}/etc/bash_completion.d/youtube-dl.sh
.endif
-.if ${PORT_OPTIONS:MFFMPEG}
-post-install:
- @${CAT} ${PKGMESSAGE}
-.endif
-
.include <bsd.port.mk>
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index d59afa795f48..0467f7daefd9 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (youtube-dl-2013.09.24.2.tar.gz) = 0ff095bd09f30c7c77758f6a74feaf163b88b06eefed5b865caedcf4623f7708
-SIZE (youtube-dl-2013.09.24.2.tar.gz) = 392769
+SHA256 (youtube-dl-2013.11.06.tar.gz) = 2cc981d150757272e5d739a098cbdd3165bdbad64832854e955e3ac918aa6631
+SIZE (youtube-dl-2013.11.06.tar.gz) = 452887
diff --git a/www/youtube_dl/files/patch-Makefile b/www/youtube_dl/files/patch-Makefile
index f29485dafe23..c384d05cca6b 100644
--- a/www/youtube_dl/files/patch-Makefile
+++ b/www/youtube_dl/files/patch-Makefile
@@ -1,23 +1,21 @@
---- Makefile 2013-07-02 05:35:23.000000000 +0000
-+++ Makefile.new 2013-06-14 23:10:06.000000000 +0000
-@@ -9,19 +9,9 @@
- PREFIX=/usr/local
+--- Makefile.orig 2013-10-17 06:55:06.000000000 +0800
++++ Makefile 2013-10-26 18:28:59.588795031 +0800
+@@ -10,17 +10,7 @@
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/man
-+SYSCONFDIR=/etc
PYTHON=/usr/bin/env python
-
+-
-# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
-ifeq ($(PREFIX),/usr)
-- SYSCONFDIR=/etc
+- SYSCONFDIR=/etc
-else
-- ifeq ($(PREFIX),/usr/local)
-- SYSCONFDIR=/etc
-- else
-- SYSCONFDIR=$(PREFIX)/etc
-- endif
+- ifeq ($(PREFIX),/usr/local)
+- SYSCONFDIR=/etc
+- else
+- SYSCONFDIR=$(PREFIX)/etc
+- endif
-endif
--
++SYSCONFDIR=/etc
+
install: youtube-dl youtube-dl.1 youtube-dl.bash-completion
install -d $(DESTDIR)$(BINDIR)
- install -m 755 youtube-dl $(DESTDIR)$(BINDIR)
diff --git a/www/youtube_dl/pkg-descr b/www/youtube_dl/pkg-descr
index bfc59b35ee55..f92fe1686520 100644
--- a/www/youtube_dl/pkg-descr
+++ b/www/youtube_dl/pkg-descr
@@ -2,4 +2,4 @@ youtube-dl is a small command-line program for downloading videos
from YouTube.com, metacafe.com, google video, photobucket videos,
yahoo videos, dailymotion and others
-WWW: http://rg3.github.com/youtube-dl/
+WWW: http://rg3.github.io/youtube-dl/
diff --git a/www/youtube_dl/pkg-message b/www/youtube_dl/pkg-message
index 2bc3d068d784..c366067483e5 100644
--- a/www/youtube_dl/pkg-message
+++ b/www/youtube_dl/pkg-message
@@ -1,6 +1,6 @@
==============================================================================
-If you want to use mp3 audio conversion please make sure multimedia/ffmpeg or
-multimedia/ffmpeg-devel is built with the "LAME" option enabled.
+If you want to use mp3 audio conversion please make sure multimedia/ffmpeg is
+built with the "LAME" option enabled.
==============================================================================