aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-12-26 17:57:39 +0800
committerrm <rm@FreeBSD.org>2012-12-26 17:57:39 +0800
commit6f7120c156594b018022bc401bbe182973abd44a (patch)
treea83a2c4c8b76de5aaa2356cbee564f4ab6dbd495 /www
parent0941a7ce2bbebf33bb2581e697d3031cd6d14f95 (diff)
downloadfreebsd-ports-gnome-6f7120c156594b018022bc401bbe182973abd44a.tar.gz
freebsd-ports-gnome-6f7120c156594b018022bc401bbe182973abd44a.tar.zst
freebsd-ports-gnome-6f7120c156594b018022bc401bbe182973abd44a.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - remove indefinite article in COMMENT - limit python version to 2.x only - remove permissions fixing part - setuptools will take care of it PR: 173231 Submitted by: rm (myself) Approved by: maintainer timeout (~2 months)
Diffstat (limited to 'www')
-rw-r--r--www/trac-datefield/Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/www/trac-datefield/Makefile b/www/trac-datefield/Makefile
index 4dbadd1fa2f4..589cd37d6d9b 100644
--- a/www/trac-datefield/Makefile
+++ b/www/trac-datefield/Makefile
@@ -1,39 +1,25 @@
-# New ports collection makefile for: trac-autocomplete
-# Date created: December 16, 2009
-# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
-#
+# Created by: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
# $FreeBSD$
-#
PORTNAME= datefield
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MASTER_SITES= http://dist.codelabs.ru/fbsd/
PKGNAMEPREFIX= trac-
DISTNAME= datefieldplugin-r${REL}
MAINTAINER= rea@FreeBSD.org
-COMMENT= A plugin for creating date fields
+COMMENT= Plugin for creating date fields
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= trac>=0.11:${PORTSDIR}/www/trac
-USE_PYTHON= 2.5+
+USE_PYTHON= -2.7
USE_ZIP= yes
-NO_BUILD= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= TracDateField
-PYDISTUTILS_NOEGGINFO= yes
WRKSRC= ${WRKDIR}/datefieldplugin/0.11
REL= 7267
-PLIST_FILES= ${PYTHON_SITELIBDIR:S;${LOCALBASE}/;;}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
-
-# We must fix file permissions -- ZIP file have 0000 for every file.
-# Directory permissions are fine (they aren't stored inside ZIP
-# file), but we set them too -- just in case.
-post-extract:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} 644
- @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>