aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-25 13:35:31 +0800
committerbapt <bapt@FreeBSD.org>2014-06-25 13:35:31 +0800
commit7081e7e5b12afca923788e24924af7212c2bc526 (patch)
tree6379d84ceeca72bc6c80702dd60bd714b378b04a /www
parentd11d1e4cc7b3c1ec281b2ea35d2fc5d85e4c5102 (diff)
downloadfreebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.tar.gz
freebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.tar.zst
freebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.zip
Convert GMAKE to MAKE_CMD
Please note that lots of invocation of MAKE_CMD here are wrong as they do not properly respect MAKE_ENV and friends With hat: portmgr
Diffstat (limited to 'www')
-rw-r--r--www/R-cran-httpuv/Makefile2
-rw-r--r--www/aws-demos/Makefile4
-rw-r--r--www/aws/Makefile4
-rw-r--r--www/fnord/Makefile2
-rw-r--r--www/libapreq2/Makefile2
-rw-r--r--www/npm/Makefile2
-rw-r--r--www/p5-libapreq2/Makefile2
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/snownews/Makefile2
-rw-r--r--www/varnish/Makefile2
-rw-r--r--www/websh/Makefile2
-rw-r--r--www/wml/Makefile2
12 files changed, 14 insertions, 14 deletions
diff --git a/www/R-cran-httpuv/Makefile b/www/R-cran-httpuv/Makefile
index 58abdd504d78..73e385ca0bdd 100644
--- a/www/R-cran-httpuv/Makefile
+++ b/www/R-cran-httpuv/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS_NODE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= R-cran-Rcpp>=0.11.0:${PORTSDIR}/devel/R-cran-Rcpp
-MAKE_ENV= MAKE=${GMAKE}
+MAKE_ENV= MAKE=${MAKE_CMD}
USES= cran:auto-plist gmake
.include <bsd.port.mk>
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index 378c3e190ff1..ad93a59f6011 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -82,12 +82,12 @@ post-patch:
do-configure:
${MKDIR} ${WRKSRC}/.build/native/debug/static/obj
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${GMAKE} setup ${CONF_ARGS}
+ ${MAKE_CMD} setup ${CONF_ARGS}
do-build:
.for dd in ${DEMO_DIRS}
@${ECHO_MSG} "=== BUILD ${dd} ==="
- cd ${WRKSRC}/demos/${dd} && ${SETENV} ${MAKE_ENV} ${GMAKE}
+ cd ${WRKSRC}/demos/${dd} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD}
.endfor
do-install:
diff --git a/www/aws/Makefile b/www/aws/Makefile
index d5631ecf1657..723f7dbdc192 100644
--- a/www/aws/Makefile
+++ b/www/aws/Makefile
@@ -152,13 +152,13 @@ do-configure:
@${CP} ${LOCALBASE}/lib/templates_parser.relocatable/*.ali \
${TEMPARSE}/relocatable/lib/temparse
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${GMAKE} setup ${CONF_ARGS}
+ ${MAKE_CMD} setup ${CONF_ARGS}
do-build:
# We cannot use a redefined ALL_TARGET because MAKE_JOBS_SAFE is set
# for PROCESSORS, but that also sets -j for gmake which breaks build
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${GMAKE} ${MAKE_ARGS} build
+ ${MAKE_CMD} ${MAKE_ARGS} build
.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} \
${MAKE_CMD} ${MAKE_ARGS} html
diff --git a/www/fnord/Makefile b/www/fnord/Makefile
index a9d4c6db77de..ca9bf2f3da8a 100644
--- a/www/fnord/Makefile
+++ b/www/fnord/Makefile
@@ -78,7 +78,7 @@ post-patch:
@${REINPLACE_CMD} -e "/strip/d" ${WRKSRC}/Makefile
do-build:
- cd ${WRKSRC}; ${GMAKE} DIET=""
+ cd ${WRKSRC}; ${MAKE_CMD} DIET=""
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fnord ${PREFIX}/bin/
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index a733670905b6..39d583661251 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -19,7 +19,7 @@ USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf libtool
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
-MAKE_ENV+= MAKE=${GMAKE} ## MakeMaker blows it without this
+MAKE_ENV+= MAKE=${MAKE_CMD} ## MakeMaker blows it without this
SHLIB_MAJOR= 11
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 5ce04f5606e2..34aee81a96e8 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -61,7 +61,7 @@ maketar: do-clean
@${REINPLACE_CMD} -e '/manRoot/ s|, "share"||' ${MS_WRKSRC}/${MS_DISTNAME}/lib/build.js ${MS_WRKSRC}/${MS_DISTNAME}/lib/unbuild.js
@${REINPLACE_CMD} -e '1 s|#!/bin/bash|#!${LOCALBASE}/bin/bash|; s|make|gmake|; s|perl -pi|perl -p|' ${MS_WRKSRC}/${MS_DISTNAME}/scripts/doc-build.sh
@${GREP} -lr share/man ${MS_WRKSRC}/${MS_DISTNAME}/doc/ ${MS_WRKSRC}/${MS_DISTNAME}/scripts/ | ${XARGS} -I % ${REINPLACE_CMD} 's|share/man|man|g' %
- @cd ${MS_WRKSRC}/${MS_DISTNAME}/ && ${GMAKE}
+ @cd ${MS_WRKSRC}/${MS_DISTNAME}/ && ${MAKE_CMD}
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type d -exec ${CHMOD} 755 '{}' \;
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -exec ${CHMOD} 644 '{}' \;
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -name '*.sh' -exec ${CHMOD} 755 '{}' \;
diff --git a/www/p5-libapreq2/Makefile b/www/p5-libapreq2/Makefile
index 00d5dbd7c00a..7f89f7d4385a 100644
--- a/www/p5-libapreq2/Makefile
+++ b/www/p5-libapreq2/Makefile
@@ -9,6 +9,6 @@ COMMENT= Generic Apache2 Request Library with perl binding
MASTERDIR= ${.CURDIR}/../libapreq2
WITH_MODPERL2= yes
-MAKE_ENV+= MAKE=${GMAKE} ## MakeMaker blows it without this
+MAKE_ENV+= MAKE=${MAKE_CMD} ## MakeMaker blows it without this
.include "${MASTERDIR}/Makefile"
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index ab7a35296b76..cf9147e4c25b 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -193,7 +193,7 @@ post-configure:
.if ${PORT_OPTIONS:MMAILNEWS} && ${PORT_OPTIONS:MENIGMAIL}
post-build:
- ${SETENV} ${MAKE_ENV} ${GMAKE} -j${MAKE_JOBS_NUMBER} all xpi \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -j${MAKE_JOBS_NUMBER} all xpi \
-C ${WRKSRC}/mailnews/extensions/enigmail
.endif
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index 1296eaf0f7cc..69dd94e9a2a4 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -47,7 +47,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|ncurses|ncursesw|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|make|${GMAKE}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|make|${MAKE_CMD}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/Makefile
.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e 's/ install-locales / /g' ${WRKSRC}/Makefile
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index c57e3626d288..2779c4b1959d 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -41,7 +41,7 @@ post-patch:
.endif
regression-test check test: build
- ${GMAKE} TESTS_PARALLELISM=1 -C ${WRKSRC} check
+ ${MAKE_CMD} TESTS_PARALLELISM=1 -C ${WRKSRC} check
post-build:
#
diff --git a/www/websh/Makefile b/www/websh/Makefile
index c97b1312d7be..fb146b4bfb8a 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -56,7 +56,7 @@ post-configure:
-e 's,-DPACKAGE_[^=]*=."[^"]*",,g' ${WRKSRC}/Makefile
post-build test:
- ${SETENV} LANG=C ${GMAKE} -C ${WRKSRC} test | ${AWK} '\
+ ${SETENV} LANG=C ${MAKE_CMD} -C ${WRKSRC} test | ${AWK} '\
/Failed/ && $$NF {failed=1} \
END {exit failed} \
{print}'
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 26b82acdde63..0a0042742131 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -43,6 +43,6 @@ post-build:
@${ECHO_MSG} "===> Use 'make test' to run a quick test suite."
test:
- @cd ${WRKSRC} && ${GMAKE} test
+ @cd ${WRKSRC} && ${MAKE_CMD} test
.include <bsd.port.post.mk>