aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-10 03:35:40 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-10 03:35:40 +0800
commit70d16163adefe907d6957b80aa6ebfe48c74ab3a (patch)
tree8e7eeab67fd5cdf35e3e52052202d9ea904b87c1 /www
parentc8bbe678a61ce9f261161e4a6469f6c39517d3fd (diff)
downloadfreebsd-ports-gnome-70d16163adefe907d6957b80aa6ebfe48c74ab3a.tar.gz
freebsd-ports-gnome-70d16163adefe907d6957b80aa6ebfe48c74ab3a.tar.zst
freebsd-ports-gnome-70d16163adefe907d6957b80aa6ebfe48c74ab3a.zip
New port: www/py-notebook
The Jupyter Notebook is a web application that allows you to create and share documents that contain live code, equations, visualizations, and explanatory text. The Notebook has support for multiple programming languages, sharing, and interactive widgets. WWW: http://jupyter.org/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-notebook/Makefile29
-rw-r--r--www/py-notebook/distinfo3
-rw-r--r--www/py-notebook/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f2cdcee2c35e..e38e58a1659f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1684,6 +1684,7 @@
SUBDIR += py-meld3
SUBDIR += py-mt
SUBDIR += py-nevow
+ SUBDIR += py-notebook
SUBDIR += py-octoprint
SUBDIR += py-pafy
SUBDIR += py-paste
diff --git a/www/py-notebook/Makefile b/www/py-notebook/Makefile
new file mode 100644
index 000000000000..86b51dc346d2
--- /dev/null
+++ b/www/py-notebook/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= notebook
+PORTVERSION= 4.3.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Web-based notebook environment for interactive computing
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}terminado>=0.3.3:net/py-terminado \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets \
+ ${PYTHON_PKGNAMEPREFIX}tornado>=4:www/py-tornado \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>=0:devel/py-nbformat \
+ ${PYTHON_PKGNAMEPREFIX}nbconvert>=0:devel/py-nbconvert \
+ ${PYTHON_PKGNAMEPREFIX}jupyter_core>=0:devel/py-jupyter_core \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}ipython_genutils>=0:devel/py-ipython_genutils \
+ ${PYTHON_PKGNAMEPREFIX}ipykernel>=0:devel/py-ipykernel
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-notebook/distinfo b/www/py-notebook/distinfo
new file mode 100644
index 000000000000..532906694420
--- /dev/null
+++ b/www/py-notebook/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483909300
+SHA256 (notebook-4.3.1.tar.gz) = 922b911f3cd1b20cf37d5ac365521586678fca4b8d20476fc369907b4a0ae1af
+SIZE (notebook-4.3.1.tar.gz) = 10162992
diff --git a/www/py-notebook/pkg-descr b/www/py-notebook/pkg-descr
new file mode 100644
index 000000000000..0b05a5cd348d
--- /dev/null
+++ b/www/py-notebook/pkg-descr
@@ -0,0 +1,6 @@
+The Jupyter Notebook is a web application that allows you to create and share
+documents that contain live code, equations, visualizations, and explanatory
+text. The Notebook has support for multiple programming languages, sharing, and
+interactive widgets.
+
+WWW: http://jupyter.org/