aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-04-01 20:05:06 +0800
committerskv <skv@FreeBSD.org>2007-04-01 20:05:06 +0800
commit74ab46e3100f4615cb3ededb23a6c70b46e928aa (patch)
tree45d64b8b458063970d674f60848f72fd5bf49169 /www
parent3afdd735ac0c274c640cb88b113299bc9a3cd40e (diff)
downloadfreebsd-ports-gnome-74ab46e3100f4615cb3ededb23a6c70b46e928aa.tar.gz
freebsd-ports-gnome-74ab46e3100f4615cb3ededb23a6c70b46e928aa.tar.zst
freebsd-ports-gnome-74ab46e3100f4615cb3ededb23a6c70b46e928aa.zip
Unbreak build: set SHLIB_MAJOR to 8 for obsolete (but still default)
Apache version 2.0
Diffstat (limited to 'www')
-rw-r--r--www/libapreq2/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 0a201824959f..b02bb3e06c6e 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -14,14 +14,11 @@ MASTER_SITE_SUBDIR=libapreq
MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache2 Request Library
-BROKEN= Incorrect pkg-plist
-
USE_APACHE= 2.0+
-USE_LDCONFIG=yes
-GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf:259 libtool:15
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
-SHLIB_MAJOR= 9
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
.if defined (WITH_MODPERL2)
@@ -57,4 +54,12 @@ post-patch:
PLIST_SUB+= WITH_MODPERL2="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} == 20
+SHLIB_MAJOR= 8
+.else
+SHLIB_MAJOR= 9
+.endif
+
+.include <bsd.port.post.mk>