aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-05-15 19:53:29 +0800
committerdirk <dirk@FreeBSD.org>2000-05-15 19:53:29 +0800
commit760af96de0801a90bb7268d0cc46fc849276c2da (patch)
tree1c29a71e6ff79046609718b25fa26c3bbb1eb7a9 /www
parentae2f18cf8192b5d824814b5b39f39e0ab5df08e8 (diff)
downloadfreebsd-ports-gnome-760af96de0801a90bb7268d0cc46fc849276c2da.tar.gz
freebsd-ports-gnome-760af96de0801a90bb7268d0cc46fc849276c2da.tar.zst
freebsd-ports-gnome-760af96de0801a90bb7268d0cc46fc849276c2da.zip
Include zlib and MySQL support if ${BATCH} is defined.
Too many people are confused if MySQL isn't included in the package.
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/scripts/configure.php46
-rw-r--r--www/mod_php4/scripts/configure.php46
-rw-r--r--www/mod_php5/scripts/configure.php46
3 files changed, 75 insertions, 63 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index a323a432710e..8f3e797a7bae 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -33,22 +31,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -203,6 +202,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index ac54e5f9076c..4f2b323c19f5 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -31,22 +29,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -187,6 +186,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index ac54e5f9076c..4f2b323c19f5 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -1,17 +1,15 @@
#!/bin/sh
# $FreeBSD$
-if [ "${BATCH}" ]; then
- ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
- ${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- exit
-fi
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
-/usr/bin/dialog --title "configuration options" --clear \
- --checklist "\n\
+if [ "${BATCH}" ]; then
+ set \"zlib\" \"MySQL\"
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
@@ -31,22 +29,23 @@ SNMP "PHP: SNMP support" OFF \
XML "PHP: XML support" OFF \
2> /tmp/checklist.tmp.$$
-retval=$?
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
-if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
fi
-rm -f /tmp/checklist.tmp.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
@@ -187,6 +186,11 @@ certificate:
EOF
;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
esac
shift
done