aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-04-30 19:10:25 +0800
committerlth <lth@FreeBSD.org>2005-04-30 19:10:25 +0800
commit76727b21e6c3ba8d84fe349b32d9b3958cfbc40a (patch)
treeff3a167fc0cd88ebd6c08c2fc54f1b05be1aaf03 /www
parent548e1e84aa9a7e0133b562f1a308627264b8ddce (diff)
downloadfreebsd-ports-gnome-76727b21e6c3ba8d84fe349b32d9b3958cfbc40a.tar.gz
freebsd-ports-gnome-76727b21e6c3ba8d84fe349b32d9b3958cfbc40a.tar.zst
freebsd-ports-gnome-76727b21e6c3ba8d84fe349b32d9b3958cfbc40a.zip
Make the module build honor the APXS variable.
PR: ports/79810 Noticed by: Jeremy Reed <reed@reedmedia.net>
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index 7faeb84e06e0..edea9df54014 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -20,8 +20,6 @@ PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
-APXS?= ${LOCALBASE}/sbin/apxs
-
# define WITHOUT_APACHE to prevent mod_speedycgi from being built even if Apache is installed
.if !exists(${APXS}) || defined(WITHOUT_APACHE)
@@ -40,6 +38,12 @@ AP_LIBEXEC?= ${PREFIX}/libexec/apache
PLIST_SUB+= AP_LIBEXEC=${AP_LIBEXEC:S/^${PREFIX}\///}
.endif
+post-patch:
+ @${PERL} -pi -e 's,apxs -q,${APXS} -q,;' \
+ ${WRKSRC}/src/SpeedyMake.pl
+ @${PERL} -pi -e 's,APXS=apxs,APXS=${APXS},;' \
+ ${WRKSRC}/mod_speedycgi/Makefile.tmpl
+
post-configure:
@${PERL} -pi -e 's,^PREFIX = /usr$$,PREFIX = ${PREFIX},g;' \
${WRKSRC}/Makefile ${WRKSRC}/*/Makefile